Need help? Check out our Support site, then


Profile picture not updating/saving

  1. I have updated my gravatar days ago, but the old picture still displays on wordpress publicly (not gravatar); the blog picture/icon under settings-general allows me to upload and says it has saved, but then does not actually save and display the correct photo; my profile picture under users-my profile appears correct, but does not display publicly. I have cleared the cache. The correct pic is a color version.

    The blog I need help with is timnewcomb.wordpress.com.

  2. Hi there,
    Gravatar images are cached and frequently take several days to display after a change. Do not keep uploading! The first place they tend to display is here in the forums and I see your Gravatar here. If several days have passed and that change is not in evidence then post here for Gravatar support > http://en.gravatar.com/site/contact-us/

  3. Hi,
    I have a similar problem. I have changed my gravatar photo and when I´m logged in the new photo is shown but after logging out the profile shows my old photo that I already removed from the profile. Cleaned the cache memory but it didn´t help.

  4. Still no resolution. My gravatar is updated, but it isn't displaying properly on my site and other sites that pull my gravatar. Another problem I see is that under Settings-General-Blog Picture/Icon where I had previously uploaded my image it isn't showing.

  5. Did you people fail to note this above?
    Post here for Gravatar support > http://en.gravatar.com/site/contact-us/

  6. I don't believe this a gravatar issue, but a blog icon issue in WordPress. The gravatar works, for the most part. Am I wrong? They appear to be two separate things.

  7. What do you mean by blog icon?
    Avatars » Gravatars http://en.support.wordpress.com/avatars/gravatars/
    Avatars » Blavatars http://en.support.wordpress.com/avatars/blavatars/

Topic Closed

This topic has been closed to new replies.

About this Topic