Need help? Check out our Support site, then


Publicize Facebook is not working

  1. Yesterday I was able to post during the day while at work, but when I went to post again in the evening at home, I received the following error message:

    To enable Publicize: Facebook, you will need to authorize your WordPress.com account on Katie's 365 Project to connect with your Facebook account.
    Clicking the link below will take you to Facebook where you will need to log in and click “allow” several times.

    Authorize connection with Facebook (link)

    -----
    I click on the link to authorize and it tells me that the connection was successful but when I try to update the post again with the Publicize box checked, it gives me the same error again.

    I know my posts are showing up on my blog page, but they're not feeding to Facebook anymore.

    It still is not working today either (though I have posted from my computer at home before and not had problems, so I don't think that's the reason). Any ideas why and how to fix it?

    The blog I need help with is katiejulius.wordpress.com.

  2. There have bee reports of this over the course of several days. Every time Facebook changes things at their end which is frequently there are problems. Volunteers cannot help you. Please report your problem directly to Staff http://en.support.wordpress.com/contact/

  3. Just in case please try this before reporting to Staff.
    1. Log into your WordPress.com blog. Go to your blog's dashboard -> "My Blogs" -> uncheck "Facebook" under "Publicize".
    (On the "My Blogs" page, make sure you're looking at the correct row for the blog in question.)

    2. Reload the page and confirm that the Facebook checkbox is unchecked.

    3. Lo into your Facebook account. Go to "Account" (upper right corner) -> "Application Settings". Remove "WordPress.com" by clicking the "X" in its row. (If there is no WordPress.com row, don't worry, just skip this step).

    4. Log *back* into your WordPress.com blog. Go to your blog's dashboard -> My Blogs -> *reclick* "Facebook" under "Publicize".

    5. Wait for the popup appear that asks you to "Authorize connection with Facebook". Click that button.

    6. You'll be taken to Facebook and asked to "Allow" several pieces. Allow them all.

  4. Thanks...will do!

  5. Also note that if that does not work for you there are 5 other ways to post to Facebook you may want to try > http://onecoolsitebloggingtips.com/2010/01/12/importing-wordpress-com-post-snippets-into-a-facebook-fan-page/

  6. Tried the "reinstall" of the app...unfortunately didn't work, so I'll contact the staff and meanwhile, look into other ways to post.

  7. Best wishes for a happy ending.

  8. Anyone have any advice for what to do if the publicize column isn't showing up at all to give me the option to publicize? Must your blog be hosted by WordPress in order to use this feature? I have it installed on my website, but I'd love to use it. :(

  9. Yes, your blog must be hosted here at WordPress.com in order for the advice in this forum to apply.

Topic Closed

This topic has been closed to new replies.

About this Topic