Need help? Check out our Support site, then


Publicize to Facebook issue with images

  1. dragonflywoman
    Member

    Hoping someone might be able to help with an issue I've been having. I use the Publicize feature to post notices about new blog posts to my Facebook page. It's not a flawless connection - it disconnects from time to time, and I have to reestablish the connection when that happens - but I've generally been happy with it. However, recently when I post a blog post and it appears on Facebook thanks to Publicize, the images that "represent" the post on Facebook are being taken from my widgets (including a series of badges and images from the Flickr widget) and not the photos from the post itself. My photos are a big reason why people visit my blog, so I'm finding it frustrating that the images that are relevant to the post do not appear when a new post is publicized to Facebook. Any ideas on how to fix the problem? Would love to hear some suggestions/get a solution!

    Thanks!

    The blog I need help with is thedragonflywoman.com.

  2. The Facebook object debugger shows that its pulling the correct image in the post area:

    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fthedragonflywoman.com%2F2013%2F11%2F27%2Fsummery%2F

    Could you try moving your Flickr widget from the left sidebar to the right sidebar?

  3. I deleted all my badges from the right sidebar because they were showing up on my publicized posts and I thought I could "force" the system to use the post photos instead by getting rid of them. After that, it started picking up the images from my Flickr widget from the left sidebar. I can try moving it, but consdering deleting the badges didn't solve the problem, I doubt moving it is going to help...

  4. @dragonflywoman
    You are not alone. I'm sorry but we cannot help with this. We have no control over the images that Facebook chooses to display or when they choose to flush their image caches. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include. From: http://en.forums.wordpress.com/topic/avalaible-facebook-thumbnail-issue?replies=7#post-1000734

    Read also: http://developers.facebook.com/tools/debug
    from: http://en.forums.wordpress.com/topic/fb-link-has-no-thumbnails?replies=4#post-936861

    See here too http://en.forums.wordpress.com/topic/pachyderm-theme-image-size-on-reader?replies=9#post-1349306

    And see this thread for more tips please > http://en.forums.wordpress.com/topic/wp-post-wont-publish-images-to-fb-but-was-previously?replies=8

Topic Closed

This topic has been closed to new replies.

About this Topic