Need help? Check out our Support site, then


Publicize to Facebook not working

  1. I've been using Publicize for nearly a year now, and it has suddenly decided to stop working. When I go to 'Manage my Blogs' it says it is enabled, but when I publish a post it says that only Twitter is enabled. When I click to enable Facebook Publicize, it says "You must authorize this connection - click here" and I click, and it says "Your account is now connected to your blog", but once again only Twitter is selected. I can repeat this process indefinitely with no result.

    I have cleared my cookies, changed browsers, changed computers, and followed the FAQ instructions (disabling it on both my WP and FB accounts, then re-activating). Nothing seems to fix the problem. It has been like this for over a week now.

    The blog I need help with is crommunist.wordpress.com.

  2. Hello there,
    As you have followed the instructions for reconnecting to both Facebook and Twitter I can only assume that you did not supply the required data or that there may be another issue that's yet to be detected.

    reference links:
    http://en.support.wordpress.com/publicize/#reconnecting-facebook
    http://en.support.wordpress.com/publicize/#reconnecting-twitter

    Perhaps you have an outdated browser issue or a connection issue. You can upgrade your browser here > http://browsehappy.com

    The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.
    How do you connect to the internet and to WordPress.com?

  3. Same thing happened to me. Also the social sharing buttons are no longer appearing at the bottom of my blog posts even though social sharing is enabled and has been since I started the blog. Seems there is an issue with WordPress.

  4. @signmeupadmin
    I can see sharing buttons at the end of your posts. I'm using Firefox 5.0. Please try these tips > http://en.support.wordpress.com/browser-issues/ If your browser is outdated please upgrade it here > http://browserhappy.com

  5. @timethief

    This is a problem that has spanned several different computers, several different browsers (which, up to a couple weeks ago, all worked just fine) and even different countries. I am not using a proxy server, I am connected through a wifi network (except once when I tried plugging my ethernet cable directly into my computer to see if that was the problem).

    Seeing as I have used the Publicize service before, I find it hard to understand what kind of 'required data' I have failed to provide.

  6. I'm sorry sorry you have this persistent problem. Facebook frequently changes things at their end. Maybe you would like to ask Staff for help. If so then here’s the link http://en.support.wordpress.com/contact/ After you use the searchbox at the bottom of the page there will be a section that says “Have you found the answer to your question?” You can choose either “Yes I found the answer to my question.” or “No I didn’t find the answer to my question and I would like to contact support for help.” The no option will reveal the contact form.

    There are alternatives. You can use Networked Blogs http://www.networkedblogs.com/ or RSS Grafitti http://www.facebook.com/RSS.Graffiti for posting to Facebook walls if you prefer.

  7. I will try that, thanks.

  8. Best wishes and I'm sorry I cannot be more helpful.

  9. I'm using Firefox 5.0 and don't see them. I also don't see them in IE9. None of my colleagues working on different computers see them either. If there were a way to send you a screen shot I would.

  10. @signmeupadmin
    I believe I may be able to help after all. As it's logical that we want our readers to actually read posts sharing buttons are placed at the end of posts. Are you clicking the post titles so the posts display on their own individual pages where at the end of the posts using Firefox 5.0 I can see the sharing buttons?

    If you want them to display on the front pag,e which only showcases your posts then you will need to choose the setting “Posts and index pages”, and the information for that which is found in the relevant support document under "troubsleshooting" http://en.support.wordpress.com/sharing/#troubleshooting

  11. Ah, makes sense. Thanks.

  12. Yay! We resolved this issue. :) Happy blogging.

Topic Closed

This topic has been closed to new replies.

About this Topic