Need help? Check out our Support site, then


Publish button goes crazy

  1. thefunkyrooster
    Member

    Hi, i've noticed in the last few days while I'm writing a post, my Publish button goes off automatically. Now my unfinished post has "Published on Date xx xx at time" which is usually the last saved date and time. I did not click on the publish button at all. Although the post has not actually been published, I still want to know what's happening.Can anyone help? Is wordpress wonky again?

    Thanks in advance.

  2. Can you give us a link to a post where this is happening?

  3. When the post is auto-saving, the Publish button will not be clickable, but it should come back as soon as it's done with the auto-save. Is this what is happening?

  4. thefunkyrooster
    Member

    It is on the page where you write your post. On the right column, you would have your save and publish button. Usually only the save button reflashes when it's on auto save. But now when it's auto saving, the publish button reflashes too. Then I get the Date and Time it has been set to publish, which was the last auto save time and date. It doesn't get published however but I'm worried it might. Think it's a glitch WordPress has to look into.

  5. I just noticed tonight that the autosave was causing the Date and Time to be set. It's definitely something going on as this has not been happening before.

  6. thefunkyrooster
    Member

    Thank God cause I thought I was going crazy. Hope WordPress is looking into it.

  7. No, you're not going crazy. They must have tinkered with something on the back end that is causing that problem.

  8. Can you get in touch with Support using the link at the bottom of the page please?
    We will need to know your browser / version.

  9. Done as requested, Mark. I'm using Firefox 3.0.3

  10. thefunkyrooster
    Member

    Ditto. I'm using Firefox 2.0.0.16. Problem only started a week ago.

  11. I've tried in FF 3 and Safari 3 on Mac and I don't see any bizarre behavior at all.

    {shrugs}

  12. All I noticed is that after you put the title in it immediately autosaves, which is a handy feature.

  13. TSP - what I'm seeing is after the autosave, instead of "Publish immediately" it shows the date and time of the autosave. (Note that this is the same problem that I have with Windows Live Writer.)

  14. OK, now I see what you are talking about. As long as I don't save manually, the "publish immediately" remains there as expected. I let my test go through autosave four times and it still says "publish immediately." Once I manually save, then the "publish immediately" changes to "published on: ...."

    Bizarre.

    I just sent in a detailed report to staff complete with links to screenshots.

  15. Glad to know that you were able to recreate it.

  16. I would think it would be a fairly simple fix really. Somewhere in the PHP there is an incorrect call or get or some such nonsense.

  17. tsp - your ticket has been received. Thanks for the details.

  18. You're welcome. I hope it is a relatively easy fix.

  19. thefunkyrooster
    Member

    Thank you scaredpath! Can't wait for the problem to be fixed.

  20. thefunkyrooster
    Member

    sorry, i mean thesacredpath. Butter fingers. :)

  21. I've filed a bug ticket over at http://trac.wordpress.org/ticket/7806

    This is something brought over from WordPress 2.7. The date/time shown you are seeing is the date/time when the draft was last saved. It's not used when you publish, but is very misleading.

  22. Thanks for the update.

  23. thefunkyrooster
    Member

    Thanks guys!

  24. thefunkyrooster
    Member

    Ok but now I can't set the time and date for the post to be publish. I tried by setting a time (10 mins later) to publish the post but nothing happened.

  25. After setting the future date/time, did you "publish" the post? WordPress will keep track of the time and date and it will not appear until the time/date that you set, but you must publish the post.

  26. "Publish immediately" wording should be back.

  27. That was quite quick. Thanks mtdewvirus.

  28. And so it is! Thanks, mtdewvirus!

  29. thefunkyrooster
    Member

    Everything's back to normal. Thanks everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic