Need help? Check out our Support site, then


Putting Google Calendar into page rather than text widget

  1. theboningtonbanter
    Member

    I need some way of running an events calendar on my blog. This is going to include multiple events, often overlapping, during the day. My original idea was to write it all into publisher and embed it in as a PDF or JPEG into the events page. This is difficult as the JPEG is too small to read and the PDF requires a non-user-friendly extra click.

    Someone suggested google calendars, which looks like it might do the trick, but it only seems to work in a text widget. I don't really want it on every page, just on the events calendar pages, and preferably then as a nice big one in the centre of the page, rather than a tiny one in the corner, which is all i've been able to create so far!

    Thanks for any help or ideas you can send my way- much appreciated!

    The blog I need help with is theboningtonbanter.wordpress.com.

  2. Have you tried it in a page? I was under the impression it would work in a page as well as in a text widget.

    http://en.support.wordpress.com/google-calendar/

  3. theboningtonbanter
    Member

    I did and all I could see was the HTML :S Sucks to be a newbie!

  4. Give it another go - I tried this and at first it didn't work but now it does. Just above the box with the code in it, you can click an option allowing you to customize the colours and the size of your calendar, and having done, at the top of the screen you then update the html and copy the updated html to paste into the page. It could have something to do with that??

  5. THANK YOU! It worked for me as a page. I really appreciate your feedback!

  6. I can't get this to work. I've followed the directions over and over and can't see that I"m doing anything wrong. I've tried embedding as a text widget and directly to a new page, both on the visual tab and the html tab. The only thing I see is that once I save and then go back and look at the code I cut and pasted, it no longer looks the same. I've also tried just adding a link to the menu, which worked the first day I did it and now no longer goes anywhere (using the link given in the google calendar settings). I've redone that several times too, trying to figure it out, and no luck. I would appreciate any help getting a google calendar embedded in any way shape or form.

  7. @marthaellyn
    Please post an active link starting with http:// to the blog in question so we can examine it and help you.

  8. Usually it's a fail because your calendar isn't set as Public.

  9. The blog is at http://litsavvy.wordpress.com/ and the calendar is set to public.

  10. All right, I've figured it out. It was a matter of using the right address from the google settings page, the html one, not the xml one. Thank you for your response, though.

  11. @marthaellyn
    If you would like to link your blog to your username so it can be instantly located here's how to do that. Dashboard -> Users -> Personal Settings -> then scroll down to Account Details. Then scroll down to where it says ‘Website‘ select the URL for your primary wordpress.com blog and then save changes.

Topic Closed

This topic has been closed to new replies.

About this Topic