Need help? Check out our Support site, then


Quotation marks facing wrong way

  1. theverysinglegirl
    Member

    Hello! I've noticed a few times that sometimes, the first quotation mark in a quotation is facing the opposite way in the post. I can't seem to figure out how to fix this. It has happened in a few of my posts, but most recently it has happened in the following:

    http://theverysinglegirl.com/2013/01/27/my-date-with-theverysinglegirl/

    Here is the text (1/4 down the page)

    ....

    “Actually, I’m kind of in the mood for a movie,” I said. ”Have anything good?”

    She proudly gestured to what she calls, ”The Entertainment Zone.” Or “The Big EZ” for short.

    ....

    It happens before Have, The, and The again.

    If you can take a look and see what is causing this to happen that would be great. It seems to happen at random...

    Thanks,

    Lauren

    theverysinglegirl.com

    The blog I need help with is theverysinglegirl.com.

  2. Hi there,
    Was that content copied and pasted from some other document?
    Or did you type it all directly into the editor on the blog?

  3. theverysinglegirl
    Member

    Hi! I typed it directly into the blog.

  4. Thanks for the answer. I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  5. Hi theverysinglegirl!

    First of all, that was one entertaining blogpost. :)

    So, in regards to the problem, I looked at the sourcecode for your page, and I noticed that there were lots of
      
    interspersed throughout your post. These replace regular "spaces" that are there when you press the spacebar. I'm not sure why those would be there, but they are the source of the issue. Out of curiosity, did you type the whole post in the edit screen, or did you copy-paste some of it from Word or elsewhere?

    Let me know, and I'll dig into it some more. Thanks!

  6. In my experience on WordPress.com, the quotation marks get turned around if you're an old-school typist like me where you insert two spaces after a period -- or somesuch -- instead of one space. Removing the extra space usually rights the wrong-facing quote mark, and I only see the mistake when the post is published, not in either edit view.

  7. theverysinglegirl
    Member

    Thanks everyone for the response!

    Richard: I didn't copy/paste any text in this post. I typed it directly into the edit screen. I've seen this happen in other posts as well. And, like boles said, I don't see the switch until I catch it in the published post. Are you saying I should go through and take out the random "&npsb;" 's in the source code to fix the issue?

    Boles: I don't do the double-space after a period...but that's a great suggestion!

    Thanks!

  8. Hi again!

    boles: double-spacing is definitely old-school! :)

    theverysinglegirl: no, you can't go through your source to remove the nbsp's because they don't actually appear in your Editor, they are somehow insterted only on the actual published post on your site. I'll look into it and see if I can find the reason.

  9. theverysinglegirl
    Member

    Thanks, any luck?

  10. Hi! I'm sorry I didn't get back to you, we don't have a fix for this bug yet, but I'm working on it with the developers. I'll get back to you as soon as I have something. Thanks!

  11. deepsouthrecruiting
    Member

    I'm having the same issue, quotation marks facing the wrong way. Didn't copy and paste from Word, typed directly into the new post editor.

    I quote in every post I publish, important we get this figured out.

    Thank You!

  12. Switching back and forth from the text editor to the visual editor sometimes adds and/or changes code as well.

    There are oddities with the visual editor.

    I have had problems with quote marks showing improperly at various times during my blogging on wp.com. It has been connected to changing from text to visual editor, or vise versa.

    These examples may seem off topic, but I've found the anomalies very annoying for years.

    Some, like centering an image, switching from text to visual will add paragraph tags to center the text but the tags are for paragraph text centering. That example may be intentional— see the support document about image alignment:
    http://en.support.wordpress.com/images/image-alignment/
    (I don't know, but maybe that is meant to simplify how to align images with text: left or right—but it messes up the code for a properly coded aligned image, especially for centered images)

    The opposite of adding stupid code to image alignment is that one is forced to switch to the visual editor in order for the fraction entities to work: & frac12; to work. ½ to show one-half… ½ — doesn't even work here in the forums.

    Why do some entities work and others do not: blank space: & nbsp ; certainly does!

    Just wondering if the way the Visual editor is quirky has something to do with the strange display of wrong-way quotation marks?

    “ & ldquo ;
    ” & rdquo ;

  13. Hi theverysinglegirl, we were able to find the source (but not the cause) of the problem: there was an errant character in your text, invisible on your site but visible in the database, that causes the quote to face the wrong way. I don't know exactly why this character ended up there on that post. I have checked your other posts and they all seem fine, so maybe this was one of those "gremlins in the machine"-type bugs. You can fix it on that post by deleting the text around the quotes (a few words or so before and after the wuote), and retyping it. Thanks for your patience!

Topic Closed

This topic has been closed to new replies.

About this Topic