Need help? Check out our Support site, then


RE: 2010 Theme

  1. If this has been answered, I apologize for posting again, but I did search first and didn't find the answer posted.

    I have chosen the 2010 default theme because it offers nearly everything I was looking for with little to change. Being an established blog though (since 2006) I have pages on my blog that have comments and though I would like for current users to be able to leave comments on some of my pages, the theme does not seem to allow it even though I've checked the option to allow comments on pages.

    I do have the custom CSS option paid for, and while there wasn't much that I really wanted to change, am willing to continue to pay for it to be able to add to the CSS to allow comments on the pages.

    Does anyone know offhand, what code to add, to do so? Thanks in advance!!

    The blog I need help with is fracas.wordpress.com.

  2. For pages, you select whether comments are allowed or not via the page editor discussion module, or if you want, go to pages > edit, and in the list check the box to the left of each page you want to turn comments off on, and then from the "bulk actions" pulldown, select edit and then click apply. You can then turn comments off for all the selected comments (or on as the case may be).

  3. You must also go to Settings > Discussion and make sure the option "Automatically close comments on articles older than [ ] days" isn't ticked.

  4. @thesacredpath - I've done that and it still doesn't allow the comments, but I see that panaghiotisadam has brought up another factor (thank you) and since I did have that ticked, I'm going to go try that and see if that's the trick.

    I'll come back to let you know either way. Thanks.

  5. @thesacredpath - Oh, sorry... I see you think I'm trying to turn the comments off on a page. What I want, is for the page to allow comments. Currently, the pages will display comments that were left when I was using a different theme, but the 2010 theme won't allow anyone to leave new comments and I do want it to.

    I have already checked to make sure I have comments turned on for the pages I want comments on... but they still do not work.

    So now I'm back to what panaghiotisadam suggested. It's odd that the only way to allow comments on a page even though that option is checked off... is to go back to having to allow comments on old posts. Closing comments on older posts reduces spam. So to have comments on pages, I will have to have an increase in spam? Seems silly.

  6. @panaghiotisadam - That did the trick, but as I wrote to thesacredpath, I think that's silly. I guess I'll write in to the WP gurus and see if they plan to (or would condsider to) address that in the backend.

    Thanks for the info!... Both of you.

Topic Closed

This topic has been closed to new replies.

About this Topic