Need help? Check out our Support site, then


Re-enabling comments for all articles

  1. Hi all,

    When I first set up my blog, I had comments switched off. Now I've imported all of my 200-plus articles, I'm ready to enable comments. I did this through the Options page in the dashboard, but it's not enabled them on my existing posts.

    It seems that I have to go through and enable comments on past posts, on a post-by-post basis - is this really the case?

    Does anyone at WP fancy running me a quick query which sets all of my existing posts to comments=Yes?

  2. Easiest method would be to do it manually post by post. There is of course the option of turning comments on and off via the Dashboard -> Options -> Discussion -> Turn on "Allow people to post comments on the article". Unfortunalty, the individual settings for the posts override this.

    Having said that, what method did you import with? If it was via the MT format, that API does have a flag you could have set to allow comments. If you still have the file, you could delete all your posts and reimport them with this flag. I'm sure you don't want to do that.

    You may want to try sending in a feedback on this one since it's a backend issue and that's usually handled via feedbacks as a ticket is needed to be created on it.

    Good luck,
    -drmike

Topic Closed

This topic has been closed to new replies.

About this Topic