Need help? Check out our Support site, then


Recent post appears on Pages

  1. I've just started this blog of mine, and basically have 3 pages - the first is the main Home page, second is an About page, and the last is a Contact page.

    What I don't quite understand is even though I published a post, it somehow appears at the bottom of both my About and Contact pages. Shouldn't it only be published on my Home page? Is there any setting that I need to configure to have the post (and any future posts) NOT appear on my About and Contact pages?

    Any advice will be most appreciated! Thanks in advance.

    Cheers.
    KT

    The blog I need help with is redtintedglasses.wordpress.com.

  2. Whoa! That is strange. Did you put the "recent posts" widget into your bottom sidebar?

  3. i'm having the same problem as kkt982...somehow, posts are showing across the top as well.

  4. @justarussianmajorfromcleveland, since your site is private, we cannot look at it. I've tried reproducing the issue kkt1982 reported and cannot on my test blog.

    Try logging out of wordpress, clear your browser cache and cookies, restart your browser and take another look. I don't know if this will help, but since we cannot see your site, we can only guess.

  5. my blog is set to block search engines but to allow "normal visitors"...it would be great to have someone look at this, because it's very frustrating. what do i need to do? i have posts flowing onto my home page and i have a duplicate topic across the top; i just wanted a static home page and a static about page....

    please advise.

  6. @thesacredpath,

    Thanks for the advice! I had the "recent posts" widget on my Showcase Template sidebar previously, but I removed it 'cuz I thought that's what's causing the issue. Problem still remains though :/

    Even after clearing my cache and cookies etc., still doesn't seem to go away. Any other idea what may be causing this issue? Am hoping to get my blog "officially" up in about 3hours' time! :/

  7. @kkt1982 and justarussianmajorfromcleveland
    I can't determine whether or not you contacted Staff. Volunteers do not have backend access to blogs only Staff do, and only they can fix bugs and make any technical backend adjustments. If you did not report this to them they will not know you are faced with this issue. So if you have not reported this then please do so now.

    Here's the link http://en.support.wordpress.com/contact/ and at the bottom there will be a section that says “Have you found the answer to your question?” You can choose either “Yes I found the answer to my question.” or “No I didn’t find the answer to my question and I would like to contact support for help.” The no option will reveal the contact form.

  8. @justarussianmajor Your blog is private, not just closed to search engines. I was curious to see the phenomenon you described. This message pops up:

    http://justarussianmajorfromcleveland.wordpress.com/ is marked private by its owner. You can:

    Request access to view the site. We'll send your username to the site owner for their approval.
    Log out and sign in as different user. You're logged in as 'mmadfan'.
    Learn about privacy settings.

  9. Hi guys,

    Thanks one and all for the kind advice.

    Seems like the problem only arises when I chose the Showcase template for my About and Contact pages, but once I change them to the Default template, the said problem goes away! However, am just wondering whether it should make sense even then for the issue to crop up depending on the template setting for the pages?

    Or maybe I should just report this to the staff as per timethief's advice and wait for their reply? :)

  10. "the problem only arises when I chose the Showcase template for my About and Contact pages".

    Of course. The showcase template is meant for the blog front. There's no point using it for your About and Contact pages as well.

Topic Closed

This topic has been closed to new replies.

About this Topic