Need help? Check out our Support site, then


red cross instead of uploaded pictures

  1. I uploaded some pictures for my front page but they dont show up and instead i got red crosses at the picture positions. What can I do and why is there not any email for contact suport? If not resolved I have to move out from wordpress..

    The blog I need help with is tzambazaki.wordpress.com.

  2. Normally the red x appearing rather than images is a issue with an outdated IE browser version. Please post an active link to a page or post you are experiencing this issue in.

    These are the troubleshooting steps we take whenever any issues like this arise:
    clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version) http://browsehappy.com/
    confirming third party cookies is enabled http://support.google.com/accounts/bin/answer.py?hl=en&answer=61416
    confirming JavaScript is enabled http://www.google.com/adsense/support/bin/answer.py?answer=12654
    confirming Flash is updated http://www.adobe.com/software/flash/about/ and if required installing the latest version of Flash http://www.adobe.com/products/flashplayer/
    resetting your router and modem and rebooting your computer
    then logging in using the secure https:// log-in see http://en.support.wordpress.com/https/
    trying another browser

    If those do not work we need to know
    (1) how are you connecting to the internet and to WordPress.com (mobile, satellite, DSL, dial-up)
    (2) exactly which browser and version of it are you using. If you don’t know click here to find out > http://whatsmyuseragent.com/

  3. I have a different problem with the image on my opening page.

    How did the computer select which of the over -12 images in text to put on the opening page? In fact it is the WORST choice imaginable! I deleted the image from the text, but there it still is on the opening page.

    How do I get rid of it?

    How do I change it for a more suitable one?

    How can I choose which image to show on the opening page?

  4. Well, just solved it!!! I opened the pictures in the PAINT program, resized my BIG pictures from some MB to few KB (70-150) and then uploaded them, and ...problem solved !

  5. Thanks for letting us know you reloved this issue. Happy blogging!

Topic Closed

This topic has been closed to new replies.

About this Topic