Need help? Check out our Support site, then


'Related post' option disappeared from dashboard

  1. I can no longer find the related post option in my dashboard. I had turned it off but want to turn it on again, but the option has disappeared from the 'Reading' page settings. My blog is writingskin.wordpress.com.

    The blog I need help with is writingskin.wordpress.com.

  2. Curious. I'm seeing it in Settings>Reading>Related Posts on nearly all my public sites but my test site, which is also public and which has 15 publicly published posts. According to the Support doc, it should appear there as well. http://en.support.wordpress.com/related-posts/

    I've tagged this for Staff assistance. Please be patient because they currently have a large backlog to work though.

  3. I noticed I have the same problem with another blog - http://cloudverse.wordpress.com/

    Thanks.

  4. Are you asking about the "related posts" feature as described here:

    http://en.support.wordpress.com/related-posts/

    Or about Zemanta, the feature that helped users find links and images to insert into their posts?

  5. Yes, I mean the 'related posts' feature as described in http://en.support.wordpress.com/related-posts/. Not the Zemanta feature.

  6. Screenshot of ablogdemo's Settings>Reading which is the only one of my 5 active sites where WordPress.com's "Related Posts" settings doesn't appear. On my other sites, it appears right after "Site Visibility" including one site whose Site Visibility settings are also set to discourage search engines.

    Neither of us are using the themes mentioned in the General Information section of the Support doc both you and I linked to above.

  7. Okay, so we may have tracked this down. Can both of you try getting some traffic to those blogs? Just ask a couple friends to visit them and click around a bit.

  8. @rootjosh - Would be grateful to understand what isn't or wasn't working.

    I clicked around the OP's two sites today so am waiting to hear from them whether the Related Posts setting now shows up in their dashboard>Settings>Reading.

    While I clicked around on my test blog while logged out, I'm not really overly concerned about it, because that is what it is and traffic isn't much of an issue there. Nevertheless, the Related Posts option does not show up in the Dashboard.

  9. I have also run into this as well.

  10. On what site?

  11. I can't recall.

  12. Meaning someone else posted this problem previously in the forums or on one of your own sites?

  13. This Staff answer appears to solve the riddle of why the option doesn't even show up in the Dashboard>Settings>Reading

    http://en.forums.wordpress.com/topic/related-posts-option-not-appearing?replies=13#post-1684204

  14. @justjennifer, I was just coming here to post the same thing. :)

    Very low traffic blogs currently do not get the related posts option added. So if the blog in question is a test blog, it's likely not to have much traffic and the related posts option may never show up for a blog like that.

    You should also note that this is the way it was initially setup, and it is subject to change—especially since it's a fairly new feature and developers may make adjustments to it as needed.

  15. Okay, it's the low volume of traffic. That makes sense since I never saw this option on my dashboard until recently and then it disappeared. Thanks justjennifer and designsimply for clearing that up.

    However I did try to generate more traffic to my blogs recently as requested, but still haven't seen the option appear. How much traffic is needed before the related post option appears?

  16. @designsimply-thanks for your clarification as well. It would be great if some mention were made in the Support doc about it. This is really an exceptional behavior as far as Dashboard settings go.

    Again, I was not so much concerned for my test site, but the OP's sites. I did click around a bit on both from two locations so am also interested in the answer to @poojachowdhary's question about how much traffic is needed.

  17. How much traffic is needed before the related post option appears?

    To be honest, I'm not sure! I'll see if I can find out more information, but do note that it's a new feature and new features often get adjusted based on feedback sometimes it takes a little time for the dust to settle.

    In the mean time, you might like this related help page: http://en.support.wordpress.com/getting-more-views-and-traffic/

  18. It would be great if some mention were made in the Support doc about it.

    I already updated the support docs based on what I know so far before my last reply (super small mention though). :) And I'll make sure to update it again as soon as I have more information.

  19. Sorry if I wasn't clear, but I was actually referring to the fact that there's no mention in the Support doc that the Related Posts option itself won't appear in the Dashboard>Settings>Reading until the needed conditions are met.

  20. Good idea. I added a requirements section: http://en.support.wordpress.com/related-posts/#requirements

  21. A few days ago I got over 100 views on my other blog, cloudverse.wordpress.com. Following that the related posts option appeared again on Settings>Reading. I assume WordPress staff did some clicking around on that blog? Thanks for that. I'll try to generate similar amount of traffic for writingskin.wordpress.com to see if it works for that blog too.

  22. I assume WordPress staff did some clicking around on that blog?

    That was me :) I was testing to make sure increased traffic was the right answer.

    I'll try to generate similar amount of traffic for writingskin.wordpress.com to see if it works for that blog too.

    Awesome! Keep in mind the traffic cannot be from anyone while logged in as a blog owner or administrator. Aim for at least 100 views, and note that it could take a day or so *after* that for the setting to appear — I was keeping an eye on cloudverse.wordpress.com and I didn't see the setting after the site got some traffic, but that was only about 1 day after the traffic appeared.

  23. Thanks for helping out with the Cloudverse blog :)

    I generated some traffic for Writing Skin, enough so that the option now appears on Setting>Reading. I've chosen and saved the 'Show related content after posts' option, but nothing is appearing on the posts.

  24. I checked the latest post: http://cloudverse.wordpress.com/2014/01/07/temporal-orbits/

    And I can see related posts appearing there. Can you try clearing your browser cache as a troubleshooting step? http://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

  25. Whoops, I mixed up the blogs when I did that last check.

    I checked http://writingskin.wordpress.com/2013/09/13/we-think-in-black-and-white/ and I see that related posts are missing there even though the setting is visible and turned on in the Settings > Reading page. I'm really not sure why they're not showing up for that 2nd blog, but I'll see what I can find out.

  26. The related posts have now appeared on the writingskin.wordpress.com blog. Thanks for you help!

Topic Closed

This topic has been closed to new replies.

About this Topic