Need help? Check out our Support site, then


Related Posts issues in Settings

  1. wildwanderingirl
    Member

    Seems this problem isn't new; I have noticed that other bloggers also cannot get Related Posts to show on their blogs anymore. I didn't have it set to show on either of my two blogs but have decided that it would be a good idea for both. A friend of mine had Related Posts on her blog and I enjoyed using them to find other interesting older posts I might not otherwise have ever known about. But RP isn't showing on her blog anymore either, at least I don't see them. I thought maybe it was an XP issue (I have two computers, one an XP desktop and the other a much newer laptop) but I don't see RP in Windows 8.1 either. I have tried the various options in the Related Posts settings but nothing helps...

    The blog I need help with is wildwanderingirl.wordpress.com.

  2. I see three related posts at the bottom of the Post

    http://wildwanderingirl.wordpress.com/2014/06/26/clematis-4/

  3. wildwanderingirl
    Member

    That is great that my visitors apparently can see them. But what puzzles me is why I cannot see them?? I don't have the "hide" option clicked either, so that isn't the reason... I looked at my blog via Windows 8.1 and, just as on my old XP, related posts is not visible for me... :-/

  4. wildwanderingirl
    Member

    Sorry about the above, I forgot to close off the italics tag, lol... Would be nice if we could edit our posts... :D

  5. wildwanderingirl
    Member

    Just today I took a tip from a friend and viewed my site in a different browser; I prefer Firefox but I also have Internet Explorer. I was surprised that on IE my related posts were displaying just fine (as were a few other features I don't see in Firefox). While I do not care for IE, it is at least good to know that the problem does not lie with me, it's a FF browser issue that I would be powerless to correct...and those who do favor IE can see my related posts...

  6. I see 3 related posts using Firefox 30.

  7. wildwanderingirl
    Member

    I checked into the menu to make sure my Firefox is up to date, and it is. All my FF add ons are also up to date. I am still not seeing Related Posts in Firefox, which is very weird since it seems they display for everyone else 0_o

    Something else I discovered was that the Like button which ought to show under each image post is not showing either. Nor do the social buttons such as Reddit, Twitter, and the rest. They all display in Internet Explorer, though ! Could be a Javascript issue but I wouldn't have a blind clue about that :)

  8. revoltastateofzen
    Member

    Hello -
    I have been attempting to resolve this issue in comments on my blog with this user and have requested the user provide a screen shot as we have some Firefox 30 similarities both browsers fully updated -

    I have checked the code on this site for this probable issue and see that related posts should display - There maybe some Fubar with the code but that should NOT affect the display in Firefox -

    Please again post a screenshot here to help with this - I can guide you through this again - I hope you can resolve this ?

  9. Do you have Adblock running in Firefox? I've noticed Firefox's ad blocker in particular blocking content that is not ads.

  10. revoltastateofzen
    Member

    Thank you, lizthe fair thank you so much for helping users - This may be the case however we will have to wait and see - Could AutoMATTic please indicate the list of third-party cookies used and their interaction with dashboard and reader - At the moment coders have been rebellious and allowed work a around -

    Coders are God's - That all me knows.

  11. wildwanderingirl
    Member

    Ah-Ha!! (I am having an ah-ha moment, lol) Now we just might be getting somewhere! I DO use AdBlock Plus, maybe that is what is causing this issue? Could be something just as simple as that. If so, I will need to know what steps to take to un-block any content from WP... If a screen shot is needed here can someone advise whether to show my actual page online, or show the area with the code? Would it be "view page source" or "inspect element"?

    Yes it is true Coders Are Gods...whilst I am but the lowliest of dusty plebians...gadzooks... :D

  12. wildwanderingirl
    Member

    Meh.......I disabled AdBlock Plus for my WP blog only, but that still didn't help...no related posts yet!

  13. @wildwanderingirl
    The long and short of this is we need all of your details. In order to help you we need to know your specific computing environment specifics. Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:
    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm
    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. You can use this link to see if your flash is up to date. http://www.adobe.com/software/flash/about/ If it’s not then go to http://www.adobe.com/products/flashplayer/ and download and install the latest version of flash.

    5. Try using another browser.

    6. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) Exactly what you experience including what any error reports you receive state.

  14. @revoltastateofzen
    Please use this link to start your own thread http://en.forums.wordpress.com/?new=1 and we will help you independently in it.

  15. wildwanderingirl
    Member

    Okay......In answer to the above, here are my sparse replies....

    (1) As indicated at the beginning of this thread, I prefer to use Mozilla Firefox as my browser and yes, I am using their latest build.

    (2) No.

    (3) Yes, Mozilla Firefox.

    (a) I have FF set to clear history when it closes.
    (b) It is set to accept cookies from sites, accept 3rd party cookies when visited, and to keep them until they expire. JavaScript is enabled, I read at Mozilla forums how to check on that.
    (c) My only add-on is AdBlock Plus and it is disabled for WordPress.
    (d) I have enabled HTTPS. That has not helped my Related Posts issue.

    (4) Flash is up to date.

    (5) As mentioned above, I see the Related Posts IF I view my blogs in Internet Explorer. But, I prefer to use Mozilla Firefox.

    (6) (a.) I use 2 computers, an older HP machine with system XP Professional, the other a Toshiba laptop with system Windows 8.1.

    (b) Firefox 30.

    (c) No error reports, just the absence of Related Posts on my blogs when viewed in Firefox.

  16. wildwanderingirl
    Member

    Screen shots on the way ASAP!

  17. @wildwanderingirl
    Yes, please post a screenshot. You can use http://snag.gy/ to share screenshots. Or you can use the WordPress.com guide I linked to and upload it to your Media Library, and return to this thread to provide the file name so Staff can examine it. I'll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  18. wildwanderingirl
    Member

    Yes, I'm patient, since this problem is not a huge stressful situation and it actually escaped my notice for quite a long time... I will post 2 screen shots since all of the HTML does not show in the Inspector text area unless one scrolls down; there doesn't seem to be a good way to just copy out the text there either...

  19. wildwanderingirl
    Member

  20. Hi there!

    I am able to view related posts on your blog across all browsers, including Firefox. The problem may be specific to your computer or Internet connection. Can you try disabling all browser extensions, ad-blocking and antivirus softwares on your computer temporarily? Then, clear your browser cache, and visit your site again? Let me know what your findings are. Thanks!

  21. revoltastateofzen
    Member

    Hello - druesome
    I feel you may be tolerant to my presence here this user is a long time subscriber to my site and an online friend -

    - I have been able to replicate this issue within Firefox by deactivating JavaScript by using the search bar config method - I guided the user through this method to the point of identifying whether JavaScript was correctly set -

    The user indicated that this was correctly set - This would indicate the user should be able to view related posts -

    If your advice above does NOT debug this issue - Perhaps starting Firefox in Safe Mode and slowly debug this issue could identify the problem for this user - Also could a conflicting older version of JavaScript that has NOT been removed be an issue here -

    I leave this in your capable hands - Thank's to everybody for helping this user.

  22. Thanks for that Zen!

    Let's see if any of our suggestions worked for the OP. Cheers!

  23. wildwanderingirl
    Member

    @ druesome - If this issue is specific to my computer, it would have to be a fantastic coincidence, as both my older XP and much more recent Toshiba with Windows 8.1 have the same problem of my related posts being invisible...

    My Internet connection is decent, not the greatest in the world but very acceptable (3-4 Mbps download)... As advised, I did disable my one & only browser extension, AdBlocker Plus, and my AVG. And my FF is set to delete browser history and cache, etc. each time I close the browser. I re-visited my blog several times after doing the above but still, no Related Posts! Curiouser and curiouser...

    So now my kind and good friend Zen advises restarting Firefox in Safe mode...also investigating whether I might have an old version of JavaScript hiding somewhere... Hmm, again, if that were the case they would be "twins" on both my computers...

  24. Hi there,

    From what I reckon, both your computers may be running a common software that may be causing the problem, perhaps a security or adblocking software or browser extension. Can you tell me a little bit more about the security programs installed on your computers? From this information, we can probably figure out what's going on. Thanks!

  25. revoltastateofzen
    Member

    Hello - druesome
    Just to confirm I don't have the issue with NOT seeing related posts I was able to replicate that issue - I believe the only common problem at the moment is with those smileys if you remember which do seem to have been herded from bothering me on my site - Thanks

    As for our security and privacy working practice here on WordPress and any system interaction with this - I can only assume we are worlds apart - I have worked through as many remote checks as possible and legal with this user and come up with nothing - The only advice left would be a complete re - install of the Firefox browser -

    I will encourage the user to return as much feedback here as possible thanks again for your help

  26. wildwanderingirl
    Member

    To be more specific, extensions are only 2-- Adblock Plus 2.6.3, and Microsoft.NET Framework Assistant 0.0.0, which is disabled... However I do have maybe a dozen plugins, would some of those have any effect?

    On XP, my only security program now is the free version of AVG...I used Microsoft Essentials in the past but now that XP is no longer supported, ME would be useless... On my laptop I have Windows Defender as default, also the same free version of AVG... Maybe that is the culprit?

  27. revoltastateofzen
    Member

    Hello -
    Slightly off topic perhaps but the admin bar jump to top navigation noticon here is NOT being recognized by my Firefox browser -

    It's still functional but the display as gone freaky !
    ""

  28. wildwanderingirl
    Member

    Hello, my friend - I see my post is showing here OK, at least for me... But now I'm guessing it is your turn to have troubles with Firefox!

  29. wildwanderingirl
    Member

    I see what you mean, at the top of this page I see the same weird little box with F435 in it!!

  30. Hi there Zen -- please open a new ticket for the admin bar issue. Appreciate it!

    @wildwanderingirl -- having a dozen browser plugins may have something to do with it. Can you please disable them temporarily and see if that improves things? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic