Need help? Check out our Support site, then


Remove categories in featured posts thumbnails on post pages (Imbalance 2)

  1. I have managed to make a regular grid of posts on my imbalance 2 theme by using the more tag to make all thumbnail text on my home page and archive pages the same length, removing category tags, and setting all thumbnail pics to the same size. This works fine.

    Now here's the problem: I have featured articles appear at the bottom of each post page. These articles don't appear as they should (i.e. like on the home page): The thumbnail text shows more text than defined by the more tag and I didn't find a way to remove category tags in this section either.

    Does anyone have an idea how to force the featured article thumbnails to appear as they do on the home page and/or remove categories? I have tried some stuff already, but somehow didn't find the right thing...

    Thanks a lot!
    Anna

    The blog I need help with is anemina.com.

  2. I checked http://anemina.com/ and I'm not quite sure where to look for the thumbnail text you mentioned. Could you reply back with an example of text so can search for it that way?

  3. It doesn't matter which post you look at. Just click on any teaser in my home page to read the full text an beneath the post you'll see teasers (i.e. thumbnails) of my featured posts. If you compared them to how they look at the home page, you'll notice that they are different: the teaser text is longer (the more tag I applied to wach post to make all teaser text the same length obviously doesn't work) and the categories also show and I want to remove them.

    I hope it's more clear now... A bit difficult to explain.

  4. a) You've added this:

    .home .categories {
        display: none;
    }

    To remove the categories from the homepage as well as the footer stickies, change it to this:

    .box .categories {
        display: none;
    }

    b) The read-more tag is designed for themes that normally display full posts on the main posts page. To adjust the number of lines in the excerpts (homepage and footer stickies alike) don't use the more tag: create custom excerpts in the Excerpt module of the post editor. If you don't see the Excerpt module while editing a post, click Screen Options (top right) and check "Excerpt" to enable the module.

    But you'll never manage to create a real grid the way you're trying to: the excerpts on your homepage have the same number of lines now, but again your posts aren't aligned because the post titles aren't similar (some take up two lines and some three). If you really want a grid layout, why don't you use a grid layout theme?

  5. Thanks a lot! I managed to remove categories everywhere :)

    I'll try out custom excerpts when I have the time, I just didn't know about that feature - and up until now applying the more tag worked just fine. Actually, I still do see a grid layout in all browsers I tried (safari for macbook, ipad and iphone as well as firefox) and it works... Apart from that I just like imbalance 2 too much to change to a different theme :) That's why...

    Thank you so much! Cheers :)

Topic Closed

This topic has been closed to new replies.

About this Topic