Need help? Check out our Support site, then


removing comment box from contact me page

  1. I made a page with a contact form, and it is showing a comment box below the contact form. Is there a way to remove it from the contact page only? Obviously, I want a comment box on my actual blog posts. Thanks!

    The blog I need help with is yesismessy.wordpress.com.

  2. My blog is yesismessy.wordpress.com, my profile seems to be linking to a missing blog? Not sure, oh well.

  3. Open the contact page in the page editor. Go to the "screen options" tab at upper right on that page and enable the "discussion" module. Now scroll down below the text area, click on the right end of the "discussion" module title bar to open it and uncheck allow comments and allow trackbacks and then click the "update" button.

  4. To change the site linked to your username, go to users > personal settings in the dashboard, scroll down to account details and in the website field put the correct URL and then save your changes.

  5. Thank you so much! I fixed both problems.

  6. You are welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic