Need help? Check out our Support site, then


Removing Comment Form in the Photo Gallery

  1. RE: http://marleneleeart.wordpress.com

    For one of the pages, I had created a gallery of my paintings. Initially, when I uploaded pictures, I was able to remove the comment form for each one when they are viewed individually. But recently I had uploaded a few more and I noticed when I view them, I see the comment form. I went into the gallery to edit the photos but cannot find a way to remove the comment form. Am I missing a step somewhere? Or I not looking at the right place?

    The blog I need help with is marleneleeart.com.

  2. Please see the comments by Tess in this thread > http://en.forums.wordpress.com/topic/disable-image-comments?replies=6

  3. Thanks, Timethief but this really doesn't answer my question. It's a page not a post. And it's a gallery page. What I wanted is to remove the comments from the individual picture of each painting in the gallery. I have done it before but I can't remember how it was done.

    It's hard to explain. When you look at my weblog, click on Portfolio page on the left side. In the portfolio are subpages for different medias such as oil, acrylic....If you click on Oil Abstracts, there will be a gallery of paintings. Then if you click on the individual ones, there be the larger version...which has the comment form that I don't want. The earlier ones don't have it and somehow I had removed. But with the newer ones they are there and I don't know where to look.

    I had check the menu for each photo but there's nothing to remove the comment form.

    Thanks for looking...maybe i have to delete those paintings and repost.

  4. Hello gain,
    I'm sorry that thread was not helpful. I think that I have seen justjennfer answer this same question but I do not have time to search for you. Perhaps the answer will be found here > Not the Official WordPress.com Gallery FAQ. > http://wp.me/p8gVp-L

  5. @marleneleeart: Posts and pages are exactly the same as far as discussion settings, media settings etc. are concerned. The thread timethief linked to includes the exact answer to your question:
    http://en.forums.wordpress.com/topic/disable-image-comments?replies=6#post-418545

    Explanation:
    When you publish a post or a page with a gallery, the so-called "attachment pages" you get when clicking on each thumbnail adopt your default Settings, not the options you select in the post or page editor.
    Whatever you change in your Settings will apply to posts or pages you create after you've made that change: it won't affect already created posts or pages.
    So the only way to have gallery attachment pages with no comment field is to disable commenting in Settings>Discussion before creating gallery posts or pages, (and override it in the Discussion module of the post/page editor for posts/pages in which you do want to allow commenting).

Topic Closed

This topic has been closed to new replies.

About this Topic