Need help? Check out our Support site, then


Removing comments from Pages

  1. breastfeedchicago
    Member

    Hello, I was wondering if there was any way to remove the comment options from Pages? I have another WordPress blog that I use as a website (www.chicagonewmomsgroup.com--it is hosted through Go Daddy and I think this is why I have more flexibility with it??? maybe?) and I am able to specify where comments are allowed and where they are not. I have the Custom Design upgrade for this site so maybe there is some CSS coding I can put in to do this?? If so, what does it need to say? Thanks for the help!

  2. You don't need to deal with CSS. Literally underneath each Post and Page is a section about Discussions where you can allow or disallow comments. Just change the setting there.

  3. breastfeedchicago
    Member

    Woops! Forgot to include that I am using the Bueno theme. Thanks!

  4. Open the pages for edit and then in the "discussions" module below the editor area deactivate "comments" and also "trackbacks" and then update the page.

  5. And raincoaster beat me to it. If the discussion module is not there, go to the screen options tab at upper right and activate it.

  6. breastfeedchicago
    Member

    This was an option on my website but not for this blog. The only option below the text is regarding Sharing buttons. I have gone to the Discussion section under Settings but it doesn't let me specify that I want to remove the option for Pages only. There is the option to Disallow people from posting comments on new articles and then below it in parenthesis it says "these settings may be overridden for individual articles" but I don't know how to do that.

    Any help is appreciated. Thanks!

  7. I think you may have missed thesacredpath's tip about going to "screen options" and making sure that the discussion module is activated. (You both posted at about the same time. :))

  8. I'm having the very same problem. It doesn't display "Screen Options" within the Discussions page, just has "Help" in the upper right hand corner.

  9. Every dashboard has a screen options tab to the immediate left of "Help". See this illustration. http://en.support.wordpress.com/screen-options/ If you cannot locate it then are you the Admin of the blog in question or not?

  10. "within the Discussions page"
    Hold it. Simply go to your Admin page and not the Discussion page.
    http://redhead81.wordpress.com/wp-admin/

  11. Once you have clicked screen options and selected the Discussion module along with the others you can then edit the pages and disable comments on them. See here > http://en.support.wordpress.com/enable-disable-comments/#enabling-and-disabling-comments-using-the-discussion-module

  12. Screen options is NOT in the discussion page. Go to either the post editor page, or the page editor page, whichever is appropriate, and at the top of that page click on screen options. There you can activate the discussion module.

  13. Thank you! I finally figured out that I needed to allow it to ask me of I wanted discussions and comments before I told it I did not want them. Much appreciated!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.