Need help? Check out our Support site, then


Removing comments option on static page

  1. Does anyone know how I can remove the comments option at the bottom of my static page when I am using a twenty twelve theme? I tried using settings and then discussion but there is no simple check or uncheck option for this theme. Thanks in advance for any assistance.

    http://edwarddegale.wordpress.com/

    The blog I need help with is edwarddegale.wordpress.com.

  2. Edit the static page in question and, down below the Write Page box is a Discussions box. Tick to disallow discussions.

  3. You will find information about how to disable comments by reading the answer provided in the following reply.

    http://en.forums.wordpress.com/topic/remove-comments-5?replies=2#post-1790863

  4. All WordPress blogs by default have comments open on all Pages and Posts. You can enable and disable comments on free hosted WordPress.com blogs on this page -> Settings -> Discussion

    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    You can override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/
    See also for faster ways:
    http://wpbtips.wordpress.com/2010/04/23/comments-off-1/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  5. Thanks for the suggestions.

    None of these solutions worked with the twenty twelve theme. I was beginning to go mad because multiple posters advocated solutions which did not provide a disallow option to click or unclick using screen options, discussion or any other solution path advanced to me.

    I was on the verge of changing themes when I tried an innocuous button on the bottom left of the screen under page attributes when in edit mode. I clicked it and it gave me the option of 1) default template, 2) front page template and 3) full width template no side bar.

    I selected front page and the comments at the bottom of that page disappeared. I repeated it for every page but my actual blog page and all comment bars at the bottom of each page updated disappeared.

    Thanks for everyone's input. I am adding all this so that if someone else chooses twenty twelve theme they wont have to figure this out all over again or question why they cant seem to follow simple instructions that seem to have been working for everyone else.

    All the best and thanks again.

  6. And when it rains it pours. Found another solution. You can also delete comments by clicking 'quick edit' instead of the 'edit' option under the title of each page when in the all pages mode.

    A box that says comments is already clicked and if unclicked, and the page updated, the comments will disappear for that page.

    Hope this helps someone.

    Thanks again for all your help!

  7. Hi @edwarddegale,

    None of these solutions worked with the twenty twelve theme. I was beginning to go mad because multiple posters advocated solutions which did not provide a disallow option to click or unclick using screen options, discussion or any other solution path advanced to me.

    I have tested the solution i have provided using Twenty Twelve theme and it worked for me without any issue.

    I think you are not getting the Discussion module on the post edit screen because by default, new blogs on WordPress.com will have the Discussion module hidden. You can reveal it by clicking on Screen Options on the top right, and checking the box that says Discussion.

    You will find more information about how to access Discussion module on the following page.

    http://en.support.wordpress.com/enable-disable-comments/#missing-discussion-module

    And when it rains it pours. Found another solution. You can also delete comments by clicking 'quick edit' instead of the 'edit' option under the title of each page when in the all pages mode.

    Yes this is an alternate way to enable / disable comments as described on the following page.

    http://en.support.wordpress.com/posts/edit-posts-screen/#quick-edit

    Keep in mind it doesn't delete the comments but disable it.

    You can also easily bulk edit comments as described on the following page.

    http://en.support.wordpress.com/enable-disable-comments/#bulk-editing-comments

    Cheers,
    Vinod Dalvi

Topic Closed

This topic has been closed to new replies.

About this Topic