Need help? Check out our Support site, then


RFE: Please add "https" support to RSS feed widget

  1. cyclofestivalgeneve
    Member

    It would be much appreciated: both identi.ca (now running pump.io) and diaspora.org send Atom feeds over https only.

    The blog I need help with is cyclofestivalgeneve.wordpress.com.

  2. Hi,

    Can you send me a link to an https RSS feed that isn't working when adding it to the RSS widget? My tests have HTTPS RSS feeds working.

    Thanks!

  3. cyclofestivalgeneve
    Member

    Here they are:

    https://dspora.org/public/cyclofestivalgeneve.atom
    https://pump2rss.com/feed/%5Bemail redacted]

    mmh, now I realize those are Atom feeds...

    The two RSS widgets configured with the above URLs both report (see bottom of my blog page) "Une erreur est survenue ; le flux est probablement indisponible. Veuillez réessayer plus tard.", whereas Thunderbird and Firefox show them correctly.

  4. cyclofestivalgeneve
    Member

    Ouch, the second URL got automatically mangled as it contains an '@' character. Here's a safe version (replace 'AT' with '@'):

    "https://pump2rss.com/feed/cyclofestivalgeneveATidenti.ca.atom"

  5. Thanks for the links. The issue seems to be neither with HTTPS or with Atom feeds, as I can have feeds with either option work, though I can confirm these two feeds aren't working.

    I'm checking into it and will send you an update when I have something more. The second feed (with the @) isn't validating, http://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fpump2rss.com%2Ffeed%2Fcyclofestivalgeneve%40identi.ca.atom , so I'm going to focus specifically on the first one for the cause.

    Thanks for your patience.

  6. It is a bug on our end. The library we use to parse the feeds is being tripped up by those. The fix isn't easy, though, so it'll likely take a bit of time for us to get it resolved.

    Cheers!

  7. cyclofestivalgeneve
    Member

    Thanks for fixing this!

    When done, please don't forget to amend your support page as it currently states:

    Feed URLs that start with “https://” will not work on our RSS Widget.

    .

    Cheers!

  8. Will do. Thanks for the reminder :-)

Topic Closed

This topic has been closed to new replies.

About this Topic