Need help? Check out our Support site, then


Robot Text and Google Ranking

  1. Hello, my website used to be listed as number 1 in google rankings for the search 'Outside the Bubble'. Now it doesn't show up in search queries at all. Nothing has changed on the backend as far as I know. If I google my website address now, I get this:

    Company Website - WordPress.com
    http://www.outsidethebubble.com.au/
    A description for this result is not available because of this site's robots.txt – learn more.

    How do I get my ranking back? And what is this robot text they're referring to? How do I amend that?

    Cheers, OTB.

    The blog I need help with is otbubble.wordpress.com.

  2. you have a couple of problems - no domain mapping - using some sort of iframe or framing to stuff your blog here onto a site - but search engines don't like the framing thing -

    also looks like you are setting up some e-commerce catalog site and that is way against the terms of service and will get your blog suspended

    nothing in the blog for a search engine to grab onto - on under construction page

    best bet - find a new host where you can do what you want to do - WordPress.COM is not a good match

  3. The observations above are about http://www.outsidethebubble.com.au/ as it currently sits - there is no robots.txt file - maybe you had one in the past that was set to keep search engines out

  4. Hi auxclass,

    Actually it's just a holding page I'm using while I set up my store on Shopify. No intention to use wordpress as an e-commerce site.

    I don't understand the tech speak of iframes etc, sorry. Nothing has changed on the backend and it has always appeared as no.1 in google ranking, so I don't understand why it is suddenly causing an issue.

    Any further thoughts?

    Thank you.

  5. Your leolol011.wordpress.com blog which seems to be the base for outsidethebubble.com has No Indexing turned on.

    See the meta name='robots' content='noindex,nofollow' tag in the page source?

    Anyway, you need to go into the Blog admin, choose Settings > Reading, and then change the fifth option down for Site Visibility to "Allow search engines to index this site".

    Note it can still take up to a month for Google etc to reindex your site. If you want to make it go a little faster, set up a Google Webmaster / Bing Webmaster account, validate the site thru Tools, and then submit the site map.xml file that WordPress.com makes.

    Regarding the iFrame for your site. I assume you are using some crappy redirect thing at your domain registrar and not the WordPress.com masking option? Very bad way to do it. Google with either end up indexing the WordPress blog address, or not at all.

    But that's another story, at least you know why your site no longer appears in search engines and what you can do about it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.