Need help? Check out our Support site, then


Share post to FB and no image appears

  1. I have tried my other blog (http://barbarastroud.wordpress.com) and when I share to FB images appear fine... however when I try to share a post http://anglinsmith.wordpress.com/2013/10/01/shannon-smith-hughes-transitions-oct-4-18-2013/ to Facebook it will not pull any images. Can you help? I tried setting a Feature Image, that didn't work. I tried deleting the last image and adding back, that did not work...
    Theme is MY LIFE...

    The blog I need help with is anglinsmith.wordpress.com.

  2. Note: The previous post (about sculptor Darrell Davis) when I tried to share that today, it DID show an image, so its just the post that published yesterday that will not pull an image...

  3. I'm sorry but when using Publicize, note that we have no control over the images that Facebook chooses to display or when they choose to flush their image caches. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include. From: http://en.forums.wordpress.com/topic/avalaible-facebook-thumbnail-issue?replies=7#post-1000734
    Read also: http://developers.facebook.com/tools/debug
    from: http://en.forums.wordpress.com/topic/fb-link-has-no-thumbnails?replies=4#post-936861

  4. It has to be a problem with WordPress... it was working fine until yesterday. Other posts work, other themes work, but not MY LIFE and not yesterday's post. I realize we have no choice of what images appear, but if you have an image on your blog it will ALWAYS give you a few to choose from. You can tell there is a problem, when you click the Facebook tab you see it try to catch and it blips, unlike when you try to share a post that everything is working...

  5. What makes you say it's WordPress.com that's the issue when clearly it isn't. Facebook software does the image selection. Have you made the same remarks to Facebook support?

  6. Yes timethief, I have made the same remarks to facebook support... this is for an art gallery (business)... so the post loses its oomph with no image... thank you for understanding.

  7. I understand that there is nothing we can do for you aside from what I posted above. :( Hopefully, you understand that too.

  8. Another thing I've noticed (whether connected or not??) is that when I set a Feature Image... there is no change in the way the image appears when I preview. Normally it becomes larger... is that not normally the case?

  9. Have you read the Images Resizing sticky post at the head of the support forums? http://en.forums.wordpress.com/topic/images-resizing?replies=4

Topic Closed

This topic has been closed to new replies.

About this Topic