Need help? Check out our Support site, then


How can I associate my shortlink with the correct post?

  1. the shortlink I used to publicize a blog post (http://wp.me/pYdBF-fl) seems to still be associated with the post when it was password-protected and is giving an error-page-not-found message to users, which is not at all what we want.

    What's wrong and how can we fix this quickly? I'm getting a lot of traffic since I posted this afternoon and I can't have people come to a blank page...

    Here's the page people are getting to:
    "Sorry, we can't find "portfoliosophiepascal.wordpress.com/2011/08/11/le-strom-spa-nordique-�-lideal-des-contrastes/". Please check the spelling of the web address."
    Blog url: http://portfoliosophiepascal.wordpress.com/

  2. Hi there,

    The correct shortlink for the post you're referring to is:
    http://wp.me/pYdBF-k9

    If you'd like to use the shortlink that you posted, you might try changing the permalink for the post at:
    http://portfoliosophiepascal.wordpress.com/2011/08/26/le-strom-spa-nordique-a-montreal-lideal-des-contrastes/

    to:
    le-strom-spa-nordique-lideal-des-contraste

    You can change the permalink from within the post editor.

  3. Hi Chris,

    Thanks for your response. I have three points:

    1. I think I did change the permalink, but I the shortlink stayed the same.

    2. Since I had to get confirmation from others before making the post public, I had published it with a password so it could be online. However, when I changed the status to "public" the shortlink seemed to still refer to the protected version because when I tried to post it to FB for example, it would say exactly that: "this post is protected, etc." I could do nothing to change that. Then people started telling me that they couldn't access the post, although the password protection had been lifted!

    I could not wait for your response and went ahead and copied the post and re-linked all the photos etc in order to get another link that works to send to people right away...

    3.Another thing: why do people have to sign in to click on the "like" button on the bottom, since I checked off in my settings that anyone could comment etc.? (there isn't a "like" button setting that I know of)

    Thanks

  4. 1. The shortlink is linked to the specific post and won't change.

    2. This is an odd caching glitch on Facebook's end, which we can't control. I don't know why, but I have had luck by asking another friend to share a post once it's public.

    3. The Like button is specific to WordPress.com, so they need a WordPress.com account to like a post.

Topic Closed

This topic has been closed to new replies.

About this Topic