Need help? Check out our Support site, then


Show posts in menu options (categories)

  1. Hi, I have set up a custom menu based on categories (i.e. Melbourne, London, Travel). I posted an entry and put it in the "Melbourne" category, and it was showing up in the Melbourne page when I was using the Book Lite theme. I've now changed to the Expound Theme and the post is now longer showing in the "Melbourne" page.
    Is anyone able to help me work out why that is?
    Thanks!!

    The blog I need help with is smallportion.wordpress.com.

  2. You have created static pages that will never update automatically. You need to create categories, assign them to published posts, and create a custom menu that you include dynamic category pages, which will automatically update, in it.

    Below is an example of a static page URL.
    http://en.support.wordpress.com/pages/

    Study it closely and note that no static Page can automatically update.
    http://onecoolsitebloggingtips.com/basic-blogging/

    Below is an example of a category URL.
    Study it closely please and note that only dynamic category pages can automatically update.
    http://onecoolsitebloggingtips.com/category/basic-blogging/

    Setting up a menu is easy as pie, provided you know the differences between Posts and Pages, and the differences between static Pages, (which will never automatically update) and dynamic Categories pages which will automatically update when you publish Posts with Categories assigned to them.
    http://en.support.wordpress.com/post-vs-page/
    http://en.support.wordpress.com/category-pages/

    Read this carefully http://wpbtips.wordpress.com/2010/06/30/posts-on-pages/

    There are many common errors, misunderstandings and misconceptions when creating custom menus and there are some tweaks you can use to improve your custom menu as well.
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/

  3. I visited your blog and clicked on "Melbourne" in the main menu and found this page: http://smallportion.wordpress.com/category/melbourne-2/

    I see one post there with the title "My first post!"

    If you're seeing something different, try clearing your browser cache as a first troubleshooting step:
    http://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

    If you're still having trouble after that, please reply back again here and make sure to include a link to the page you're looking at.

Topic Closed

This topic has been closed to new replies.

About this Topic