Need help? Check out our Support site, then


SHOWCASE / POST SLIDER INSTRUCTIONS

  1. masterworksstudiollc
    Member

    Greetings everyone. It appears as though this post slider issue is very common, and I'm yet another person that is stymied. Below are detailed instructions I've compiled based on all the forum posts and WordPress documentation. I would appreciate anyone's help in determining where I am going wrong as I've spent 6 hours so far banging my head against the wall.

    I will admit I'm a little disappointed in that the template I've selected - Hero - doesn't default to looking *exactly* like it's viewed in the demo. Although this seems to be the case with all the templates (I've tried Oxygen and several others that have a post slider available), I don't understand why the post slider cannot be pre-built. Why cant the template have a default static showcase / home page and a post page, then 2-3 example photos that can be replaced with your own pictures on the front slider? This would appear to me as an excellent way to get someone up and running ASAP.

    When I choose a template I'm not just examining the font and background, etc. - I'm also looking at the layout. A layout that isn't defaulted to exactly what I see in the demo doesn't seem to be a template. But maybe that's just my naiveté.

    Anyway, here's my instructions using the Oxygen template. Someone please show me where I'm wrong. Items in < > are the buttons you click on with my commentary in regular text. First thing you do is go to dashboard, and we're going to start as if you don't have any posts or pages. I'm starting with a clean slate and photos already loaded in my media library.

    1. Push <Pages> then <add new> and click in the very obvious 'enter title here' rectangle and name the page "Home".

    2. Go to far right side and you'll see 3 big grey boxes titled Publish, Page Attributes, Featured Image. Go to Page Attributes box and you'll find Parent, Template, Order. Click on template dropdown arrow and you'll find default, full page width, showcase page. Click showcase page. Go to Publish box just above your Page Attributes box, push blue <Update> button. Don't do anything else.

    3. Go to top of page and see "Edit Page"; click <add new> and title it 'Posts' and <Publish>.

    4. Go to <settings> on the dashboard. Click and view <General> <Writing> <Reading> etc. Click <Reading>. You are sent to Reading Settings. First thing says "Front page displays.' Default is to 'latest posts', but you need to click the Static page radio button. Then hop down to 'Front page" and click <select> drop down arrow. Click <Home>. At 'Posts page' line click <select> and <Post>. Scroll down to bottom of page and <save changes>

    5. Go over to left and click <Posts> then <add new>. Title this post 'Test 1.' View <add media> button; look to far right of this and find <visual> and <text> tabs. Click <visual>. NOW click <add media>. You are sent to Insert Media webpage. Click <media library>

    ***Now, this is important: supposedly you need pics that are 750 pixels wide for the slider to work properly. If you don't have ones this size, reupload some big pictures so you can continue and hence click <upload files> to do so. Go through that process before continuing).***

    6. Insert Media page, click a big pic and you'll see a big grey rectangle on the right with 'Attachment details' and 'Attachment display' settings. Down below the latter is 'alignment' and 'link to' and 'size'. Go to the 'size' dropdown arrow and select full size. You'll see at that point if your pic is above 750. Click <insert into post> and you're taken back to your Add New Post page. Click <publish>. You will now see your posted image and it will say you published x number of posts.

    7. Click <new post> and do this all over again with 2 more posts named test 2 and test 3.

    8. Go back to dashboard and click <posts> then <all posts>. View your posts. You SHOULD see the word 'image' after each post name, but for some reason I only occasionally see the word there...even though I check back and there is indeed an image on the view tab in the post. Makes no sense to me, but whatever. Keep on page.

    9. View <bulk actions> and <apply> buttons. Below the former you'll see 'title"; click the check box on the left. All three of your posts will be check marked. Click on <bulk actions> and click <edit> and <apply>. A huge "bulk edit" window will push down your posts. Go all the way over to the right side and view 'sticky'. Click <no change> and <sticky>. This will - supposedly - stick all the photos from your post to the showcase page, your "Home" page.

    ***IMPORTANT*** I'm going to pause here as this does not occur for me. I have no photos visible on my Home page whatsoever. When I look on my Posts page I have all posts there from most current to oldest...but there's a grey box for each photo. Clicking on each box takes me to the individual post whereupon I can view the photo. If I click on the photo it will open up to its full size.

    I've then added 3 more posts selecting the exact same photos, but this time shrinking them to thumbnail size (~ 200x300 instead of ~3840x2560, say). Same result.

    Now, if someone could please indicate what I have done wrong here I would certainly appreciate it. If you could describe exactly what I'm supposed to do, in the same way I've done up above, it will not only help me with this problem but will very likely resolve this Showcase / Post slider problem once and for all.

    I'm glad most everyone has eventually solved their problem (and even indicate the happiness in their forum post!), but the final 'solution' they've found does not seem to be described in a detailed way that it can bring this innumerably posted issue to a close.

    Please, please *please* give me some detailed instructions. I'm now signing off to find the First Aid kit and bandage up my damaged cranium.

    The blog I need help with is masterworksstudiollc.wordpress.com.

  2. This thread will be moved to the Themes Forum where Themes Staff will address your issues.

  3. masterworksstudiollc
    Member

    Very much appreciated.

  4. Howdy masterworksstudiollc,

    Thank you for your detailed explanation, I will do my best to answer it with the same attention to detail.

    You SHOULD see the word 'image' after each post name, but for some reason I only occasionally see the word there...even though I check back and there is indeed an image on the view tab in the post. Makes no sense to me, but whatever.

    The word 'image' only appears there, when you select it to have an Image Post Format. Post Formats are not supported by every Theme. Oxygen for example does not support Post Formats, so I assume you had a different Theme active, when these posts were assigned the Image Post Format.

    To make the images appear in the slider, it is not only important to mark the post as sticky, but also to assign it a featured image. A featured image work differently than the images to embed in you post content. It serves as a representation of the post and is not part of your actual post content.

    To assign a post a featured image, go to the dashboard and click <posts> then <all posts>. Click on the title of the post you want to edit. Go to far right side and look for the gray box with the title "Featured Image". Click on the blue link <Set featured image>. You can either upload a new image file, or click on <Media Library> to select an image from your previously uploaded pictures. Click on the blue button on the bottom right <Set featured image> and then hit <Publish> or <Update>.
    If the picture is big enough it *should* show up in the featured slider.

    I hope I could help you along - please let us know if you have any further questions!

  5. masterworksstudiollc
    Member

    Thanks, kobenland, for the quick response. I had to work on something else so I haven't had a chance to get back to this issue until now.

    Yes indeed, I *did* upload the photos within different themes as I was struggling to get this up and running; I changed to the Oxygen theme in an attempt to mimic exactly the work done in the forums.

    I went back to the Hero theme - that I originally wanted - and deleted all posts and images and started over with the two original pages, Home and Posts. I retained the <Settings> <Reading> <Static> for the Home page and then created 3 test posts and immediately published without any images; I wanted to follow your directions exactly as you had provided. Upon creating the posts, I then uploaded 3 quite large photos and went to the Test 1 post. <Visual> <add media> selected the first photo, went to 'Attachment Display Settings' <size> <full size> <insert into post>. Edit Post page, 'Featured Image' <set featured image> selected same picture from media library <set featured image>, Edit Post page <update> Edit Post page <Posts> <All posts> Post page <Title check mark> <bulk actions> <edit> <apply> 'sticky' section <sticky> <update> Posts page. Went to top right, hovered over <masterworksstudiollc>, hovered <W masterworksstudiollc> clicked <Read Blog>

    and...

    ...still didn't work. On 'Home' page, went to 'My pages are below' <post>, all posts are there with huge photos (horizontally limited by column width, of course).

    Is there a widget I need to put on the home page? I don't see one under Widgets related to Post Slider and the only thing I put in the Primary Widget Area is <Pages>. Removing this Widget does what it says and has no impact on a post slider (as it wouldn't have any affect... tho I'm trying everything I can think of).

    I sure appreciate your help, kobenland, as I'm at wits end.

    Thanks again.

  6. masterworksstudiollc
    Member

    You can examine the blog, I suppose, and see what it looks like presently: masterworksstudiollc.wordpress.com. If you'd like I'll even give you the username and password off-line (I'll change it afterward, of course) and let you confirm my settings.

    Whatever helps.

  7. Hi there,

    Setting up the featured post slider in Hero works differently than in other Themes. You can find out more about it on the theme's documentation page.

    Please let me know if you have further question after following the instructions on that page.

  8. masterworksstudiollc
    Member

    Ahhhh...... I see. Whelp, you're of course correct: once I changed the theme back to Oxygen it worked just fine. Thank goodness. I realize now I should have kept it on Oxygen anyway as that was the one we were talking about (I thought all the themes with post sliders would use the same steps).

    And thank you for highlighting the theme's documentation page, as I hadn't stumbled upon that for whatever reason. I will closely examine Hero's instructions and follow them to the letter. Now that I better understand the process and how to wield the tools I should be up and running shortly.

    I can't thank you enough for walking me through this particular issue... especially in great detail. Hopefully this thread will effectively solve the Oxygen post slider issue once and for all, as it now works perfectly for me.

    *** Important to people reading this post: you *do* need to know that once you complete the steps above the resulting post slider will truncate/clip your photo to the template's rectangular viewer. If you have square or 3x5 photos with, say, faces or landscapes, you may find the heads/legs or sky/trees to be cut off. You'll need to modify your featured photos (before you post them) in such a way that the photos are modified to the size of the rectangular viewer. Run some test posts. I'd suggest 3. After you set up the post slider using the instructions above, look at your blog Home page and you'll see how you'll need to clip the pics to make them look right. You may be able to modify their placement somehow and won't need to use this little trick, but I've worked on this issue for long enough! I'll continue to monitor this thread anyway to see what you come up with.

    Hopefully my need for highly detailed instructions will come in handy for others working on this issue.

    And if you have any questions, kobenland has been - thankfully - patient with me and I'm sure he'll work closely with you to solve any further issues you may have.

    Good luck!

  9. I will! Glad it worked out for you! :)

Topic Closed

This topic has been closed to new replies.

About this Topic