Need help? Check out our Support site, then


Showing all posts on Posts page rather than Home page

  1. Hi,
    I wanted to show all my posts on a "Posts page".

    After following link given beloe, I found that I don't have "Front page diaplays" section in my Settings ->Reading.
    How's that possible?

    http://en.support.wordpress.com/pages/front-page/

    Can someone help me with this?
    Thanks!

    The blog I need help with is nikhilpingle.com.

  2. thesacredpath
    Staff

    It would be right at the top of settings > reading as shown in this screen cap.

    http://flippintestblog.files.wordpress.com/2011/12/settings-reading.png

    The only way that would not show is if you are logged in as something other than an administrator. Go to Users > All Users and see what "role" is assigned to the username you are logged in with.

    The other thing to try, if you are logged in as an administrator, would be to log out, clear your browser cache and cookies, restart your browser and then try again.

  3. It still doesn't work.
    I am logged in as administrator.
    Also, I tried restarting browser, but its not just showing there.

    Is it theme specific, or something?
    I am using clean home theme.

  4. This is not theme specific. You create two pages. One page is for your Welcome page (or whatever you wish to call it). The other is for your posts "Blog" or whatever you want to call it. Then you go here > Settings > Reading and assign the pages you created accordingly.
    Front page displays
    __Your latest posts
    __A static page (select below)
    Front page: choose from drop down menu
    Posts page: chose from drop down menu

    If that's what you have done and you cannot assign the two pages then you need to contact Staff for help.

  5. You need to actually have at least one published page before you set a static front page at Settings -> Reading.

    You'll need two pages if you want the posts to appear on another page, but this second page can be blank.

  6. I clicked into your blog here http://nikhilpingle.com/ and noted that you have deleted the "Hello World" placeholder post. That has created this error message "Not found
    Sorry, but you are looking for something that isn't here." on your front page. When you actually publish a post that "404" (page not found) error message will disappear.

  7. I have 8 pages in total, including Home and Posts pages.
    It shouldn't matter if pages are privately published, right?
    {
    I on purpose kept these pages private, as this website is gift to my boyfriend, and don't want to get revealed before his birthday. :)
    }

  8. All right!
    Got it working, I made all pages public.
    I think all pages were Private, and hence that part was not showing.

    Anyways, Thanks a lot all of you! :)
    I will keep bothering you all till December 9th, I should be completing everything on this site before that. :)

  9. Yes it matters. Please see here:

    Public – The page will be visible to everyone.
    Protected – The page is protected with a password you set. Only people who have the password can view a protected page.
    Private – Pages are only visible to blog Editors and Administrators. Private pages are not visible in Blog Surfer, feeds, or in any search. A page can be private without being password protected. http://en.support.wordpress.com/pages/page-visibility/#private-blog

Topic Closed

This topic has been closed to new replies.

About this Topic