Need help? Check out our Support site, then


Side Bar is Missing from My Home Page

  1. All my widgets are missing on my home page. If I click on an individual blog, they show up then.

    The blog I need help with is fimupdate.wordpress.com.

  2. Have you consulted your theme description http://theme.wordpress.com/themes/selecta/ and live demo site http://selectademo.wordpress.com/ and verified whether or not the theme is designed to display widgets on every page of the blog?

    Widget Areas
    Selecta comes with four widget areas — one in the left sidebar, and three in the footer. The footer widget area will appear only if you have added widgets to it.

    If you have then the next thing to do is to open the widgets and make sure the visibility settings are correct. Widgets now have "visibility" settings so we can select which pages they display on. See here: http://en.support.wordpress.com/widgets/#widget-visibility

  3. Thanks for the reply. It's been working for the past 2 years til now. How do I contact my theme description once I get to the page you linked me to?

  4. This is where you can read your themes description http://theme.wordpress.com/themes/selecta/

    Have you gone here > Appearance > Widgets and opened the widgets and confirmed the visibility settings inside them are correct? Widgets now have "visibility" settings so we can select which pages they display on. See here: http://en.support.wordpress.com/widgets/#widget-visibility

  5. yes, I have. they're all good. problem started when wordpress changed the layout on the widget manager page. tried moving a widget from the default column to the first footer, then it showed up in the default column. of course when I selected a single blog, then it really did show up in the first footer. could use some help. thanks!

  6. Thanks for confirming the visibility settings on the widgets. I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting as it is the weekend.

  7. thanks! will do. did find my widgets on the home page. they're at the foot of the page, even though they're placed in the default

  8. Hi again and thanks for the added information. Sidebars and widgets in them do not fall to the bottom and display below posts and/or posts do not appear in sidebars unless

    (1) content has been imported into the blog

    (2) the blogger has been copying and pasting content from elsewhere, without using either icon 5 or icon 6 in Row 2 of the visual editor http://en.support.wordpress.com/visual-editor/#pasting-text

    (3) or the blogger has copied and pasted invalid HTML into a text widget or left an HTML tag open

    After you go here and enable this > Settings > Writing
    Formatting
    _ WordPress should correct invalidly nested XHTML automatically
    "save changes"

    See here for sorting this out > http://wpbtips.wordpress.com/2012/05/19/sidebar-at-the-bottom-and-related-issues/

  9. Option #2 was the solution to the problem. I was using Evernote to write, copying and pasting it onto WordPress. Thanks the for the help! Problem solved

  10. Hi there,
    I'm happy to know you have resolved this. Do make sure to enable this > Settings > Writing
    Formatting
    _ WordPress should correct invalidly nested XHTML automatically
    "save changes"
    Happy blogging! :)

  11. Yep, did that. Thanks again!

  12. Have a great weekend. :)

Topic Closed

This topic has been closed to new replies.

About this Topic