Need help? Check out our Support site, then


Sidebar moves on it's own accord :-(

  1. Hiya,

    Been writing to the WordPress office for ages, but never get a reply: the sidebar of my blog keeps moving to the bottom of the pages or back to the side every time I post. Why is this? It's so frustrating!! I want it to be at the side and stay there!!
    Can anyone help? Or do they know how to move it back when it happens?
    Cheers,
    XX

    The blog I need help with is davidwalliamsnewsnewspage.wordpress.com.

  2. First off if you scroll down your main page, do you notice the very long URL's in a couple posts hanging out and into the sidebar area? Make those into text links instead of just pasting in the URL since that can cause the sidebar to go south.

    The other thing that can cause it to go south is mangled or open HTML tags in posts, and your front page is reporting 47 of them on the validator. Go to settings > writing and select "WordPress should correct invalidly nested XHTML automatically" and then click "save changes."

    Now, starting with your latest post, open it in the editor, make one minor change such as adding a space and then deleting it, and then click "update post." Check your blog and if it is back to normal, you are golden. If not, open the next post and do the same thing till it goes back to normal.

  3. This is an extremely common problem, generally caused by:

    1) images or tables too large for the main column
    2) pasting from Word
    3) pasting from elsewhere on the web
    4) bad code.

    If you go through your posts one by one, you'll see the problem occurs in this post:

    http://davidwalliamsnewsnewspage.wordpress.com/2010/11/10/david-walliams-big-book-battle-matt-lucas-new-dj-job/

    and you can see you have two different colours of font, grey and black, and assorted issues.

    To prevent this in future, go to your Dashboard->Settings->General and select "Wordpress should correct invalidly nested XHTML" which means it'll fix your code if it's got tags left open, etc, which is what happens when you paste from Word or elsewhere on the web. Then go in and edit that post; edit it in the HTML view and make sure that you don't have funny colour tags halfway through the post, etc. Then Update it, and the problem should be fixed and not recur.

  4. Thanks :-) Wonder why they couldn't tell me when I asked :-)!!
    Will try now!!
    XX

    Ps. Re the long url, I had those before, but it just broke off neatly before the sidebar or went into the sidebar, never pushed it away. Weird :-/X

  5. I have viewed the blog linked to your username which is wearing the Pressrow theme using Firefox 3.6.12 and IE8. I can see no problem with the way your sidebar appears so I assume you have resolved this issue.

  6. Hiya,

    Hopefully, for now at least :-)
    Thanks again, everyone :-)
    XX

  7. Hiya,

    Happened again and again :-(

    I changed everything, shortened links. Now it can look good at first, but it moves away later (and I only spot it when I get back later).
    I'm spending hours restoring, but no change :-( ...
    XX

  8. Whatever you are doing, like copy-pasting, stop doing that. Did you change your XHTML settings?

  9. If you click on each post one at a time, you can clearly see the problem is in this post:

    http://davidwalliamsnewsnewspage.wordpress.com/2010/11/21/david-walliams-and-lara-stone-at-x-factor-david-closer-to-bgt-pictures-and-more/

  10. Really don't see what's wrong with that one :-/, especially as it was fine when I posted it yesterday ...

    Some of the things advised I can't find. Is it different if it's non paid for?
    XX

  11. Can you be a little more specific than "Some of the things advised I can't find."? What, exactly? Go to Settings->Writing and it's right there. Select

    WordPress should correct invalidly nested XHTML automatically

  12. This one: Dashboard->Settings->General and select "Wordpress should correct invalidly nested XHTML"

    I can't find it :-/
    XX

  13. I got it wrong the first time. It's Settings->Writing.

  14. Thanks :-) I found it now!! Hope it works :-)XX

  15. Nope :-( ...

  16. If you have not done this, give it a try. With the "wordpress should correct..." selected at settings > writing, open each post on your main page, make one minor change such as adding a space and then deleting that space and then click the update button. Do that with each post on your main page.

    The reason I'm suggesting this is that according to the W3C XHTML validation report, there are a lot of XHTML errors on your main page, mostly having to do with either unclosed tags or improperly nested XHTML tags. WordPress should correct those if you have the above selection set at settings > writing.

  17. THose come from copy/pasting, so don't do that in future.

  18. On the lower tool bar, there are two icons for pasting. Paste from Word and Paste as plain text. Use Paste as plain text when copying and pasting from the web or sources other than MS Word. It will strip out all the code so that what comes in should be clean with no errors.

    http://en.support.wordpress.com/visual-editor/

  19. If my above procedure (opening post, adding and deleting space...) doesn't fix the issue, then start with your most recent post, highlight everything in the post and then click the "remove formatting" icon on the lower tool bar. You can then edit the text and add in whatever formatting you need to and then update the post. Do that with each post on the main page.

Topic Closed

This topic has been closed to new replies.

About this Topic