Need help? Check out our Support site, then


Sidebar problems, "Twenty Eleven"

  1. Hi,
    I am having trouble with my blog http://www.thatswhatsheread.com.au, specifically with the sidebars. It was all working well, and I decided to change themes. I changed to "Kent"(which only allows sidebars on the footer of the page) but finally settled on "twenty eleven".
    My sidebars will not move from the footer of the page.

    I have followed Support's Layout instructions (found here - http://en.support.wordpress.com/themes/layout-issues/). When I change "reading settings", so that the blog posts 'show at most' setting is 1, and the problem continues to occur for all pages.

    I would appreciate help so that my sidebar is on either the left or right side of the screen, please!

    If I go into "customise" and adjust the settings, it looks perfect in the 'sample'. I click 'save' but there is no change to my page. Also - when I refresh my page, the content window doesn't take up the whole page - there is space for the sidebar. But then it seems to 're-refresh' and the content takes up the entire page.

    I am viewing on an ipad - could this be the problem? I want my page to be the same irrespective of the device it's viewed on.

    The blog I need help with is thatswhatsheread.com.au.

    The blog I need help with is thatswhatsheread.com.au.

  2. From my desktop, I checked out your site and the widgets appear in the sidebar. I guess that the problem is that Twenty Eleven is a responsive theme, meaning that, when viewed on a mobile device, it will adapt to the screen size. On my tablet, the screen is big enough that, in landscape view, sites using Twenty Eleven display like they do on a desktop. But if I turn it into profile mode, the theme adapts, and the sidebar gets placed in theh footer.

    If this responsiveness is not what you are looking for, you'll need to use a theme that is not responsive--though it looks like you already tried a different one while I was typing!

    The Forever theme is fixed width, so unless you choose "Enable Mobile Theme" in Appearance -> Mobile, your site will always display the same way.

  3. Thanks ecumenicallife!

    Yes I worked out it was the responsiveness causing me problems - is there a way to turn it off that you know of?

    Thanks!

  4. No, you can't turn off a responsive theme--it's coded that way, to allow users on smaller screens to be able to see your blog and all your widgets, but also allowing your content to take up as much space as it can so that readers can still read it on the smaller screen.

    If you don't want your theme to change and adapt to mobile devices, you can use a fixed-width theme and make sure that in your Appearance -> Mobile settings you check No to "Enable mobile theme". While this will force every device to diplay your blog like it would on a desktop screen, it will make your blog very difficult to read on a mobile device. You won't have much trouble on an iPad, but someone on an iPhone will struggle.

Topic Closed

This topic has been closed to new replies.

About this Topic