Need help? Check out our Support site, then


Single quotation marks are published as double quotation marks

  1. Within the past few days WordPress has changed its code so it now publishes all single quotation marks as double quotation marks - with two exceptions: (1) if my opening single quotation mark is immediately preceded by a non-space character, it is published as a single quotation mark, and (2) if my closing single quotation mark is immediately followed by a non-space character, it is published as a single quotation mark.

    I always use double quotation marks when I cite someone's words, and I use single quotation marks when I want to emphasize a specific word or words in my own text flow. This precious distinction is now gone, and everything gets double quotes, with one really weird-looking exception. If a single quotation string of words is followed by a comma or a period it is published with an opening double quotation mark and ends with a single quotation mark.

    I have just written my very latest blog post, numbered 1.451, solely with examples for you to see what happens in the various situations mentioned here above.

    I dare suggest that this is a newly invented bug, not a change of policy. Would you kindly look at what WordPress did about this during the past few days? I would like WordPress to return to publishing the quotation marks of the same type as I write, if that is doable.

    Forgive me for being what you might regard as a stinking pest about this, but this feels to me as if a real plague has suddenly hit me.

    The blog I need help with is gymbrat.wordpress.com.

  2. Are you typing directly into the editor, or copying and pasting from another program?

  3. It does not matter. I usually write on Word and copy it into the WordPress editor using the method provided by WordPress, but in the example in my post number 1,451 I wrote directly into the WordPress editor. Everything, including my existing 1,450 posts, now suddenly gets displayed in the problematic way that I described.

  4. Have you tried this just in case it may help?
    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    Posts > All Posts, change all your latest posts to Draft, click Update, change them back to Published, click Update again. (You can edit all of them at once: tick the square in front of their titles then select Edit from the Bulk Actions dropdown and click Apply.)

  5. Thank you for your suggestion. However, my Settings > Writing > "WordPress should correct invalidly nested XHTML automatically” is already selected and has always been selected - I have never touched it.

    My single quotation marks have been displayed as single quotation marks all through the years until a couple of days ago, and I did not change anything in any of my settings recently. The problem is due to some code change that WordPress just did, and now all my existing 1450 posts show my single quotation marks as double quotation marks in the manner I specified.

  6. I flagged this thread for Staff attention and for moving to the Themes Forum. Please be patient while waiting.

  7. I've tagged this for staff attention and hopefully they will be around to look into this. I suspect with WordPress 3.4 now in Beta that they have thrust it upon their 30 million unsuspecting beta testers (all the bloggers here at wordpress.com) and their are bugs.

    Either that or they are on some sort of grammar correction crusade to save people from themselves.

    I do the same as you with the double and single quotes, so this would affect me as well - if I blogged here anymore.

  8. ...and *there are bugs.

  9. One other question: If you open your test post in the editor and switch to the HTML tab, does it show the single quotes as a single quote character, or does it show it as an HTML code something in the form of &4576;

  10. I hope this is a bug and NOT an intentional change on the part of wordpress. I have author clients that use single and double quotes as you do and they are going to freak if this is an intentional change.

  11. In the WordPress editor the single quotation marks remain as I wrote them, whether I use the editor in visual or HTML mode. I can switch back and forth between the modes and my quotation marks remain as they are and should be. It is only when WordPress places them on the theme that they appear as double quotation marks in most places.

  12. I have flagged this thread for a Theme Staff response.

  13. I think this is an editor issue and they are changed when you publish and the content is sent through the filters they have set up.

  14. @thesacredpath
    interesting ...

  15. Hello gymbrat,

    It took a bit of testing, but I was finally able to reproduce this on a test blog. The issue should not affect blogs in English, but other languages may have issues. Your site's language is Svenska which is affected by this bug. We are looking into this and will let you know once a fix is in place.

    Thanks for reporting!

  16. Michaelfields, thank you so much for your analysis, and I am in no panic to get the bug resolved, only that I know that it is identified and on a to-do-list somewhere.

    However, contrary to your idea, the bug applies to English just as Swedish. I happened to write my latest blog post, number 1,451, in English so that all of you would be able to read what each example identifies. And that post shows double quotations all along with the English text. Unless of course my whole blog is stamped as Swedish no matter what.

    Thank you for repairing!

  17. The language refers to the setting at Settings -> General in your blog's Dashboard, not necessarily the language you write the post in.

  18. Thank you for letting me know that.

    I suspected the possibility when I just wrote "Unless of course my whole blog is stamped as Swedish no matter what.".

    You just confirmed that possibility. Thank you for that. I know that I am in good hands.

  19. Update: we tracked down the problem to an actual translation of a single quote in a double quote in the Swedish language files.

    Here's the strings in questions:
    http://translate.wordpress.com/projects/wpcom/sv/default?filters%5Bterm%5D=wp-includes%2Fformatting.php&filters%5Buser_login%5D=&filters%5Bstatus%5D=current&filters%5Bwith_context%5D=yes&filter=Filter&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

    If this is incorrect with the regard to the Swedish language, you can suggest a new translation to be reviewed by the language moderator.

  20. Thank you so much for submitting your extract of the current character code translations as they pertain to Swedish. I have not changed anything in your submitted code translation table, since I have no idea what havoc I could cause. But I have studied it in detail, and I see what went wrong on 2012-04-02.

    I would suggest that you let the 8216 (opening curly single quote), 8217 (closing curly single quote), and 8220 (opening curly double quote) character codes remain as the 8216, 8217, and 8220 codes that they originally were before 2012-04-02, when you changed them all to 8221 (closing curly double quote). In short, it appears to me that if you let all of the character codes in the right part of the displayed table be the same as they are in the left part of the table, then the result would be perfect.

    I avoid being more precise, because I don't know how your system determines a single or a double quote, in my writing, to be an opening or closing quote.

  21. @gymbrat: thank you for your suggestions. WordPress.com is translated by volunteers - everyone can suggest translations, and designated validators for each language approve them. I contacted the validators for Swedish WordPress.com and asked them to review this thread and adjust the translations as/if necessary.

Topic Closed

This topic has been closed to new replies.

About this Topic