Need help? Check out our Support site, then


Site uses https?

  1. Some of the links going into my blog use https. I'm curious as to why it doesn't simply use http, there's nothing secure.

    The blog I need help with is teknophilia.wordpress.com.

  2. If you sign in to WordPress.com via a non-secure Internet connection, like a public Wi-Fi connection at your local coffee shop, your account may be more vulnerable to hijacking. To keep the bad guys out, we recommend selecting the “Always use HTTPS when visiting administration pages“ option from your Personal Settings page (Dashboard > Users menu > Personal Settings) which will SSL-encrypt your connection while in the WordPress.com dashboard. Save the change by clicking Save Changes. When you log back in, you’ll be rolling with SSL encryption. http://en.support.wordpress.com/https/

  3. Sorry > here's how to rid yourself of the security warnings > http://en.support.wordpress.com/https/#how-do-i-get-those-annoying-security-warnings-to-go-away

  4. Log out, clear your browser cache and cookies, restart your browser and then go to it without the https, just use the http

    In your dashboard, if you wish you can set things up so that you go in via https or you can disable that. You can enable or disable https connection at users > personal settings.

Topic Closed

This topic has been closed to new replies.

About this Topic