Need help? Check out our Support site, then


Skydrive embedding issues

  1. I am having issues skydrive embedding content. Following http://en.support.wordpress.com/excel-web-app/. If I go back to the visual tab I see the yellow box but if I save or preview it does not show on my blog post.

    The blog I need help with is jariangibson.com.

  2. Does this help?

    If you can’t preview your posts, pages, or themes on your blog – you may need to enable third-party cookies in your web browser. http://en.support.wordpress.com/third-party-cookies/

  3. Hey there,

    Can you link to an example post where you're having this issue so I can look into it further? Additionally, can you please post the embed code that SkyDrive provides you here?

    Best,
    P.

  4. I can see everything else fine. Just not content embedded from Skydrive. It shows in the editor window but as soon as I save it goes away.

  5. Here is code

    <iframe src="https://skydrive.live.com/embed?cid=7F5AC1619C23241D&resid=7F5AC1619C23241D%21445&authkey=ADWQWorxKZae0T8&em=2" width="402" height="327" frameborder="0" scrolling="no"></iframe>

    The blog is private post since it is not working yet.

  6. According to the link above it is supposed to convert the iframe when I hit update. It is removing it when I do that. If I switch from the text tab back to the visual tab before hitting update I can see the yellow box for it, but as soon as I hit update it disappears. Also if I preview before hitting update it does not show in the preview.

  7. from:
    http://en.support.wordpress.com/code/

    WordPress.com is a type of shared environment, where all users are running off of the same software. This is great because it allows us at Automattic to update millions of blogs at the same time with a single click. It means we can fix bugs or offer new features very quickly, which is a win for you as users. Having all users running on the same software can also be dangerous. If we aren’t careful, one user has the potential to take down the entire site. So this is why we need to limit some of the things you post on your blog.

    If you wrote some code or pasted it in from another web site and then it disappeared after publishing the post, the code is likely being stripped out.

    and

    If you are familiar with HTML, you’ll notice that codes such as embed, frame, iframe, form, input, object, textarea and others are missing

  8. I understand that but what is the point of this following article then?
    http://en.support.wordpress.com/excel-web-app/

  9. Also on the code paste above changed https to http.

  10. Aha! I don't post excel docs so I was unaware of this! Thanks for the update, but apparently it is still a buggy feature. Always glad to learn something so I'll keep watching this thread.

  11. Hi jariangibson,

    I'm sorry to hear that you're having trouble. Hopefully we can help you sort this out.

    Currently, our SkyDrive embed only supports iframe's with r.office.microsoft.com as part of the URL. In the code you posted above, the URL is skydrive.live.com.

    I am curious how you generated that skydrive embed URL? I just logged on to SkyDrive, created a new PowerPoint document and clicked on 'File > Embed this Presentation' and the code it generated for me was at r.office.microsoft.com and I was able to embed it properly at WordPress.com.

    Since the instructions vary slightly for PowerPoint documents vs. Excel documents, I've created a new support document at the following url:

    http://en.support.wordpress.com/powerpoint-web-app/

    Can you please try again with the instructions provided?

  12. I will try this. I uploaded an existing PowerPoint and tried the same instructions from the Excel link. Thanks!

  13. jariangibson, if you wouldn't mind replying back once you've tried, I would appreciate knowing if this is resolved or not. If you aren't able to get an embed code with 'r.office.microsoft.com' in the URL, we'll need to update the way our shortcode for SkyDrive works.

    Thanks!

  14. That worked. The issue is I was using the Office Web Apps preview in SkyDrive. I turned off the Office Web Apps preview and now it works like it should. Something to keep in mind for the future when SkyDrive Office Web Apps get upgraded. The url will use skydrive.live.com instead of r.office.microsoft.com. Thanks for your help!

  15. Great, thanks for the feedback!

Topic Closed

This topic has been closed to new replies.

About this Topic