Need help? Check out our Support site, then


skype button

  1. hi,
    iv put a skype button on my about page and though it shows my status ,its not pulling up skype,i think becoz wordpress adds the http://redmind.worpd.... instead of skype:username. Could some one plz tell me if there's anyway to get "skype me" to work.

    Odeo works great btw,maybe thats becoz its just a link

  2. What's the full Skype address?

    You need to ensure that it has http:// in front of the URL otherwise wordpress will think it is a relative url and point within wordpress.com. Eg

    cornellfinch.com will go to http://wordpress.com/forums/cornellfinch.com which is obviously wrong,

    but http://www.cornellfinch.com will go to My Website

    Hover over the two links to see the difference.

    Hope this makes sense and helps!

    Collin

  3. thank you,, yeah wordpress does make it a incoming link.
    I think i understood whats happening.The
    "skype:skypeuser?call" which actually starts skype and makes the call is in javascript(IUt doesnt point to http:skype.com but to my skype on my comp)and wordpress doesnt support javascript,which i just read in another post in support.So maybe thats why its not working.But nonetheless it does show my status and also becos itl act as a skype banner im going to leave it like that.

    Thanks for your help cornell,appreciate it

  4. I just did a Google search for skype & wordpress and located the following that looks interesting. I have not yet tried it but thought I would pass it on:

    http://anti.masendav.com/2005/11/skype-button-for-wordpress/

  5. That's for the WP blogs hosted elsewhere as it requires a plug in as well as a modification to the theme.

    Thanks by the way. I did not know about that one myself. Have to see about adding it over here. :)

    -drmike

  6. hi drMike,
    I was trying to add skype me to my blog and it did not work out since it was a java script. On seaching the forum came across the above. Just wanna check if there are any updates to the above as you had mentioned.
    Tx.

  7. Fraid not. Javascripts are still removed from input for security concerns. If you really need Skype, I would suggest getting a paid host.

  8. Mike I dont want Skype that bad :)
    I am very comfortable here
    Anyways if we have some restricted way of getting in scripts of embed flash file , it would open up lot of doors (of course both good and bad) ... Hence will wait until we can control the bad :)

    Tx for the update Mike

  9. Well, I can't miss an opportunity like this to plug myself. If anyone wants to request IM status widgets here on wordpress.com how about point the folks in the direct of my IM Online widget.

    Go on. It'll make me happy.

    As for the original thing. What skype is doing in the URL isn't Javascript but calling a "skype protocol" address using a standard URI. If it's stripped by WordPress it's a bug.

    In an url anything that is before a ":" is a protocol (as in http: <- protocol address -> //www.wordpress.com or ftp: etc.)

    Just a test: test

    (Edit: Yup, stripped. Bug. Pah! I'm guessing this is to guard against javascript:

    Really would be better to prevent that specifically rather than every non-http / ftp protocol. Feedbaaacckkkk.... )

  10. I believe I may have found the answer - using tips from some of the earlier comments I started playing with the syntax and protocol we are trying to put in a link.

    (I'm using skype v2.5)
    1.In skype, under options, in the Advanced section tick Associate Skype with callto: links.

    2.Type the word press link like this
    callto://skypename

    3.save and get ready for all the calls !

    Hope that helps...

  11. I still getting problems.
    When i get the code to insert from skype for the buttons i get a code...

    So, i ofc strip out the js part and keep the 'img' and 'src' tags in the code.

    For the 'img' tag there is no problem, but even if i switch the href from 'href="skype:MyAccountName?call"'(given in skype website) to
    'href="callto://MyAccountName"' (as suggested here)
    once i update i get this code : 'href="//MyAccountName"'

  12. @iout
    Did you notice above what drmike said?

    Fraid not. Javascripts are still removed from input for security concerns. If you really need Skype, I would suggest getting a paid host.

  13. Actually in this case it's because skype and callme are being stripped. They're not XML recognized tags and staff has stated that they won't be supported.

  14. @timethief
    i know, js was indeed stripped as i wrote

    @drmike
    i get it, i tried inserting the 'callto:\\' links both in a text widget, both in a blog article. The result is always the same, the WP platform cut the protocol part resulting the HREF tag pointing at '\\whatever'.

    But i still don't get what this has to do with WP host security, since the protocol is simply passed to MY browser wich WARN me that that link is calling an application on MY machine, not on the host where WP host my blog, and this happens only if that protocol is registerd on MY machine by the external application.

    I'm just curious, maybe i'm not enough malicious (or on the other hand enoug ignorant :P) to see the possible exploits. I also noticed some forum platform (eg. http://www.simplemachines.org/) doesn't recognize the 'callto://' protocol in a link i tried to post,resulting in adding 'http://' just in front of the link.

    Regards.

  15. I think it's more of a XML issue and trying to stay verified than a security issue in this case.

Topic Closed

This topic has been closed to new replies.

About this Topic