Need help? Check out our Support site, then


Social media buttons don't work

  1. The social media buttons that came with the theme don't work properly, usually they just load a blank page (although they can be fine with some devices and not others).

    Also, I want to add a text widget with code from meetup.com for a side bar button but the same thing happens.

    If I right click on any of them and open the link in new window they work!

    How can I get them to work on all devices on the first click? Thanks for your help!

    The blog I need help with is englishvoicenl.wordpress.com.

  2. All three work properly for me. I am on Windows 7 using FF29.

    Please work through what follows and report back.

    1. If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode. http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    3. If you are running one of the browsers and versions listed at http://browsehappy.com/

    (a) Try clearing your browser’s cache http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:
    http://browsers.about.com/od/howtousemobilebrowser1/ss/safari-ipad-clear-cache.htm
    http://browsers.about.com/od/howtousemobilebrowser1/ss/How-To-Clear-Browsing-Data-In-Chrome-For-Ipad_6.htm

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled
    http://en.support.wordpress.com/third-party-cookies/
    http://www.google.com/adsense/support/bin/answer.py?answer=12654

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS: http://en.support.wordpress.com/https/

    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    4. You can use this link to see if your flash is up to date. http://www.adobe.com/software/flash/about/ If it’s not then go to http://www.adobe.com/products/flashplayer/ and download and install the latest version of flash.

    5. Try using another browser.

    6. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to WordPress.com.
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/
    (c) Exactly what you experience including what any error reports you receive state.

  3. Thanks so much for the detailed list of things to try. I did everything off the list except the following:

    I didn't really understand how to do 3c and I managed the first part of 3d (enabled HTTPS) but couldn't figure out the second bit:
    Add both *.wordpress.com and *.wp.com to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.” http://en.support.wordpress.com/https/#frequently-asked-questions

    Everything is up to date. The button links still don't work.

    So the answers to question 6:
    a) MSi laptop with windows 8, New iPad Air (all updated).
    b) On the laptop I'm running firefox 29, on the iPad I've got Mobile Safari 7
    c) There are no error reports. On the laptop, if I click on one of the social media buttons or the meetup button it seems like the destination will load in the same window because it goes blank white and says 'connecting' briefly in the address bar, but then nothing happens and you're left with a white screen. If you click back, you don't go back to my site either.
    On the iPad, you press hold one of the buttons and get a menu, if you touch 'open' nothing at all happens. If you select the next option 'open in new tab' it works fine.

    Interestingly if I go to the full site on my Samsung Galaxy s2 and press hold on the logos, I get a menu where the first option is also 'open' and in this case they do! On the phone I've got the Android 4 browser.

  4. I'm glad they worked for you btw! :)

  5. Thanks for reporting back to provide details. I'll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  6. @languagelego
    Please ignore the spammer. I have reported it.

  7. @timethief Cheers!

  8. They worked just fine for me using Chrome. Maybe you were not signed in when you tested them?

  9. @raincoaster I'm glad to hear they do work on some browsers, but I would prefer to know they work everywhere.
    I was signed in to wordpress when testing, but really they should work for any visitor to the blog, whether they have wordpress or not, shouldn't they?
    This is something I've lived with for months, they've never worked for me and a couple of contacts who reviewed the site for me said they didn't work for them either which is why I'm determined to get this sorted now!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.