Need help? Check out our Support site, then


some images have disappeared from my blog

  1. Hello,
    I can see all of my images for all of the posts when i am logged in. However, if I am not logged in some images are not showing (which means my audience can't see those images). I have never experienced this before. What can I do?

    The blog I need help with is knowingmoldova.wordpress.com.

  2. Could you share a link or two of the posts where the photos are not showing up? I looked at your blog and see several images on your front page.

  3. ~~thebirdingbunch
    Good question. I can see images too.

    @peahen
    (1) Are these missing images found in your Media Library ie. on WordPress.com servers? Or are they hosted on another site?

    (2) If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html
    a. Have you tried clearing your browser cache and cookies ? http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    b. Have you tried updating the browser to the latest stable version? http://browsehappy.com/

    (3) For details about the options for uploading images see:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    (4) For troubleshooting images tips see > http://en.support.wordpress.com/images/troubleshooting-images/

Topic Closed

This topic has been closed to new replies.

About this Topic