Need help? Check out our Support site, then


sourcecode blocks copy poorly

  1. When I use [sourcecode] blocks on my wordpress.com blog they look reasonable, but when users try to copy the code (which is, after all, a big part of the purpose of putting code blocks on a blog entry) the text is mangled.

    http://randomascii.wordpress.com/2012/01/11/tricks-with-the-floating-point-format/

    The paste operation, whether to Visual Studio or to notepad, inserts five blank lines after each line of code. Double spacing would be bad enough, but sexta-spacing?

    This is annoying that it makes me want to not use the [sourcecode] tag. Is there any way of avoiding this problem?

    The blog I need help with is randomascii.wordpress.com.

  2. I'm sorry that's happening to you. If this posting source code section is not helpful you will have to contact Staff for assistance.

  3. The HTML in these cases doesn't contain anything hidden from view, and what you're describing isn't happening when I copypaste from your examples or the relevant Support doc into TextEdit (on a Mac). Perhaps you need to adjust some setting or preference in the applications you're using.

Topic Closed

This topic has been closed to new replies.

About this Topic