Need help? Check out our Support site, then


sourcecode links broken with language highlight

  1. If I write the following code enclosed in [sourcecode] tag:

    $ wget http://download.savannah.gnu.org/releases/qemu/qemu-0.12.5.tar.gz

    ...it will display also a clickable link to "http://download.savannah.gnu.org/releases/qemu/qemu-0.12.5.tar.gz".

    but if I set the language as "bash" the word "tar" will be highlighted because it could be a bash command, and the clickable link will lead to "http://download.savannah.gnu.org/releases/qemu/qemu-0.12.5." which is incorrect.

    You can check what happens on this post.

    Is it possible to have autolinks options default to false when the code language is set, since it is currently broken?

    The blog I need help with is balau82.wordpress.com.

  2. Hi. If I understand correctly, the autolinks option leads to broken links when language="bash" and to override this, you have no choice but to put autolinks="false".

    Please report it to staff directly because we volunteers have no control over the back end of [sourcecode]:
    http://en.support.wordpress.com/contact/

    FYI for everyone else:
    http://en.support.wordpress.com/code/posting-source-code/

  3. Thank you! I just contacted them and I'll keep this post updated.

Topic Closed

This topic has been closed to new replies.

About this Topic