Need help? Check out our Support site, then


Spam Comments added to media attachments rather than the actual post

  1. The amount of spam caught by Akismet is amazing. But I'd rather the spam be blocked up front so it doen't happen at all. I think there is a serious flaw in the settings area for discussion.

    For example - I make sure a specific post is UNCHECKED in the discussion settings so to not allow comments. But if I go to the same post and click on any IMAGE - a gallery opens opens and that allows for comments. It even says trackbacks and pings are closed but you can comment.

    This where your serial spammers are working, and creating all that waste of time. The main culprits are lista de emails as everyone knows.

    Is there a way to close off the availability of comments via the media attachments - or is this a flaw that you should take a good look at in order to fix this annoyance.

    You can easily test this on any blog.

    Thanks.

    The blog I need help with is jmmnewaov2.wordpress.com.

  2. Attachment pages adopt the default discussion setting, not the setting of a particular post. So you need to disable comments in Settings > Discussion (and enable them in the Discussion module of each new post you create, when you want that).

    By the way, you don't have to use attachment pages - see here:
    http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.