Need help? Check out our Support site, then


Static Front Page and Featured Content Slider?

  1. Hello,

    I'm using the Blissful blog theme on wordpress.com to make an artist portfolio. The front page should feature my portfolio works with the featured content slider. That's working so far.

    However, it seems that when I set a static front page, which has information about the portfolio pieces that appear in the featured content slider, the featured content slider disappears. I have a feeling it's just the way Blissful Blog is coded, so I've transferred the information about the portfolio pieces onto a stickied post.

    I want only this post and the featured content slider to appear on my front page, but what I'm getting is the stickied post AND my latest post after that. Is there a way to get rid of this? Under the Reading Settings, I've reduced 'Blog Pages show at most" to 1 post.

    The blog I need help with is farahkhanart.wordpress.com.

  2. Hi there,

    You're correct, Blissful Blog is designed to show the featured slider only on the "latest posts" view, and not on a static front page.

    Technically, the way you have the front page set up now is the intended behavior. Each time you click the "Show Older Posts" button, it counts as the "next page". It shows one post each time you click the button, since you have set your blog pages to show 1 post per page.

    It's possible to hide the button with CSS, available with the Custom Design upgrade. If you do get the upgrade, I'd be happy to help provide the necessary CSS.

    Hope this helps!

  3. Okay, I see how this works now. Thank you very much!

Topic Closed

This topic has been closed to new replies.

About this Topic