Need help? Check out our Support site, then


Static home page not static

  1. I am setting my home page to static with a separate page as the posts page. But the home page still brings up all the post like content that I don't want.

    How do I make the front page so that only my content shows up with no other links or posts on the page?

    I have gone through all the forums and followed the instruction on creating the static page on the support pages, but it is not working.

    Could it be the theme? I am using "Panel"

    Blog: professionalsconnect.wordpress.com

    The blog I need help with is professionalsconnect.wordpress.com.

  2. By default the front page of your blog displays all published posts (not pages) in reverse chronological order, with the most recently published post on top. That is for the convenience of your returning visitors, who come to read your latest post, and who are not likely to be happy with being compelled to click through the same static page with the same blah, blah, blah on it every time they visit the blog looking for the latest post.

    However, if you do not want all the posts to show on the front page, then you can create a static front page called for example “Welcome” for your site and a “Blog” page for posts. To do that create two pages first http://en.support.wordpress.com/pages/

    After you do that you go to > Settings > Reading and make the designation change and click “save changes”.
    http://en.support.wordpress.com/pages/front-page/

    A static page (select below)
    Front page:
    Posts page:

    See: http://en.support.wordpress.com/images/gallery/
    http://en.support.wordpress.com/slideshows/

Topic Closed

This topic has been closed to new replies.

About this Topic