Need help? Check out our Support site, then


Static Home Page, 'Posts' Page Not Showing Data

  1. I made the Home Page static under Settings and the category 'Blog' as the page where posts would appear.

    The posts however are not updating on that page. Perhaps my settings are off. It has copy there about this being the home widget area which I'm not sure how to get rid of. When I put a post up that said 'coming', nothing appeared. And the actual widgets, which appear to the right on the other pages, are to the bottom and to the right on that page.

    Thanks for your help!

    The blog I need help with is takeforwardwbai.wordpress.com.

  2. On the blog linked to your username, http://washingtonsquarepark.wordpress.com/ , I don't even see a "blog" page, and the posts are showing on the main home page. It is not static.

    If you are talking about a different blog, then you have to give us a link to it. We can't help if we cannot look at it.

  3. Sorry ... I linked it to that site when I entered the question (I thought).
    The blog address is: http://takeforwardwbai.wordpress.com

    Thanks!

  4. You have things set up correctly, you just don't appear to have any posts published yet. If I click the post title "blog" on the "blog" page, I get to a permalinked single-post page.

    If you have created posts, go into posts > posts and look at the far right column on the list that comes up. Published posts should have a date with "published" underneath. Draft posts will have a date and "last modified" in that far right column.

  5. There's a post published on August 30th but it doesn't appear in that Blog spot. I can view the page here: http://takeforwardwbai.wordpress.com/2010/08/30/hello-world/

    Thanks for your reply and help! It seems like it's stuck somewhere...

  6. Actually if you open that post in the editor, what you will see is that the actual title of the post is "Blog" but if you look right below the title field at the URL permalink, you will see that it reflects the URL you listed above. That post is showing, but the difference between the title and the URL is what caused the confusion.

  7. I'm not sure I understand what you are saying. To me, they are totally different views...

    What shows up is this: http://takeforwardwbai.wordpress.com/blog/
    (yes the blog text is there but it has to be scrolled down to view - at least when I'm looking at it.)

    What I want to show is this: http://takeforwardwbai.wordpress.com/2010/08/30/hello-world/

    It doesn't look right when you click on Blog ...

    The 'hello world' version should be seen when you click 'blog.'

    Thanks for your help, again.

  8. http://takeforwardwbai.wordpress.com/blog/ is the page you set up to show your blog posts. That page will show your posts in reverse chronological order (newest at top).

    http://takeforwardwbai.wordpress.com/2010/08/30/hello-world/ is the "single-post" or permalink page for the post that you titled "blog" (which was originally "hello world" but you retitled it).

    The blog page has the featured image section at the top (the big grey area). There is no way to hide that on the blog page.

    Perhaps you should look at different themes that do not have the featured image thing at the top.

  9. Oops, not sure how that got posted, I wasn't actually done and needed to edit.

    If you want your "blog" post to show in the featured post section at the top, then you have to go to theme options and select which category you want to use for "featured" posts. Then you have to assign that category to the featured post.

  10. @jc, you are about to be banned from the forums for life. Enjoy it while you can.

  11. Cathryn, the other thing to remember is that the post "blog" will only show up in the top featured area if it has an image

  12. Hi... thanks for going through this with me. I guess a lot of it is the theme but I'm finding this perplexing. So the 'hello world' post is not viewable anywhere? That's just a 'throwaway' sort of, it sounds like.

    I added a test image to the post, I assigned it a category 'documents' and I made that the category for "featured" posts.

    But the image shows up on 'hello world' but not on 'blog.'

    It's a little baffling to me to say the least. I like the theme but I did want to add something to the Blog (I understand how the posts would be structured like typical blogs...) that would look more uniform to the rest of the Pages.

    Sorry to make you spend so much time on this but I appreciate it. I may have to work around that somehow and make a new Page for the documents and leave that basically blank for now or do something else with it.

    Thank you!

  13. You renamed the "hello world" post "blog."

    Go to posts > posts in your dashboard and look at the list. You will not see a post called "hello world." Open the post called "blog" and look right below the title bar to the "permalink." You will see at the end of the permalink it says, "hello-world."

    To back up to the title field, delete "blog" and type in "hello world" and then click the update button. Now go to your blog and go to the blog page. You will now see the "hello world" post.

    You had renamed the hello world post and that is the reason it was not showing up as "hello world." You renamed it "blog" and that is what it shows up as.

  14. Do this just as a test.

    Go to posts > add new. Create a test post and name it what you want and put in just a little bit of text and then click publish. Click on add new again and do the same thing, this time with a different title.

    Visit your blog and go to the blog page. You will see those two new posts above the old one you have that is named "blog."

  15. Hi The Sacred Path,

    I did everything you suggested, I think... and I can live with the way it's set up which is okay. I get the way it's supposed to be now generally ... except for that big blank space up top which doesn't guarantee that anyone will scroll down to find the posts. I know you had to said to upload an image ...but perhaps I did that piece wrong. You can see what's up there now and if you haven't run out of steam on this if you can tell me if there's anything I did wrong or is that what you meant?

    Thank you!

  16. @Cathryn, with the theme you have chosen, nothing will show in that top section till you insert some images to your posts. Then your latest post will be highlighted there. The image has to be inserted into the post, and then the post has to be in a certain category that you have set as the featured category.

    Go to appearance > theme options and you will see that "uncategorized" is set as your "feature" category. From that pulldown, choose "documents" as that seems to be the category you have put all your posts into and save. Now go back to your blog page. You will see the title of your latest post above the grey box, and in the right you will see the text of your latest post.

    The large grey box is for the featured image (pulled from the post) and will remain blank unless you put an image into each new post.

    My feeling is, that structure really isn't the theme for you since there is no way to disable that featured post section and make it disappear.

  17. You might want to look at Coraline, Wu Wei, or Twenty Ten. They may be better suited for you if you are not going to be using images in every post.

  18. Hi TheSacredPath,

    I get it! Thank you so so much. I've worked with Wu Wei in the past and I'll look at the others. I do like the 'look' of this theme but now I totally understand what's going on on that page. (I did make the featured category 'documents' the other day.)

    Many many thanks for your patience and explaining this through my many questions!

    best,
    Cathryn.

  19. I know this is not the place for private hosted WP, but it's the only post I've found in weeks that addresses exactly my problem. I do not yet have a solution to mine however. I was fine until I switched to Permalinks. I was posting, and it was showing up fine: http://quantumfieldclearing.com/blog Site home is static.

    I have site set reading to Static Home, and Blog for Viewing Posts. As I said, it all worked fine for days, until I went to PermaLinks for a more user-friendly browser url, and my own linking in widgets - and then NOW no more posts will appear on the blog page.

    I use These 1.8, WP 3.01. and this only happens when I switch to Permalinks. I wonder if I switch back (then I do have to change all my widgets, I can query sql I guess), and that might be worth it.

    I went back to Default links, but just in case it is obvious to anybody what I need to know? THANKS!

  20. You need to inquire over at http://wordpress.ORG/support/ as that is where self-hosted wordpress blogs are supported. Since we do not have any permalink choices here we haven't the foggiest idea what the problem might be. WordPress.ORG can help you though.

  21. Oh, after I changed to PermaLinks, I did a blog post :
    http://quantumfieldclearing.com/2010/10/acep-va/
    but unlike the others you see on the BLOG page that were done before PermaLinks, this one doesn't show at the top of the chron Blog Page.

    Thanks for any help.

  22. Okay, thanks very much, @thesacredpath. Will do.

  23. Like I said we can't mess with permalinks here so we have absolutely, positively, no experience with changing permalinks or what kinds of issues that can cause. Any answers we would give would be a complete guess, and not a guess based on any knowledge.

    You need to inquire at wordpress.ORG. We haven't a clue here.

Topic Closed

This topic has been closed to new replies.

About this Topic