Need help? Check out our Support site, then


Static Pages not Separated

  1. coppershavings
    Member

    I have created three pages that should display separately: Home, About the Author and About the Name. All three of these pages display on the Home page, even though they are defined as having no parent. How do I get them to stand alone?

    The blog I need help with is coppershavings.com.

  2. Please read the differences between posts and pages. Pages are static and are for content that rarely changes. They sit outside of the blog structure and you cannot post to multiple pages in any blog. There is only one main page for posts in a blog and all posts will display on the main blog page. There is no way to exclude posts from the main posts (blog) page.

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page "Welcome" for your site and a “Blog” page for posts.

    Choice 1 static front page
    Choice 2 running page for all posts on front page

    Which do you choose? It’s one or the other.

    If you choose Choice 1 static front page then you have to create two pages as I said above. After you do that you go to > Settings > Reading and make the designation change and click “save changes”.

  3. coppershavings
    Member

    Thanks for the quick response, however I'm not having a problem with posts. Currently I have created zero posts. I have three pages, the content of each should only appear on its own page. My Home page should show only the content I created for it. The About the Author page should only show that content. The About the Name page should show only that content. My problem is that the Home page shows the content of all three pages with the last page shown first, even though the sequence number of that last page is higher. How do I get the Home page to show only the home page content (plus any posts once I start posting)?

  4. That is too weird.

    Go to posts > all posts and make sure those pages are not somehow listed there.

    Also, are you using the standard blog set up, or have you activated the "news" template and set that as the static front page?

  5. coppershavings
    Member

    Nothing shows in the posts section of my dashboard. I'm wondering if this has anything to do with the fact that I think I inadvertently deleted my "main" page early on in creating this thing. Is there any way to recover or recreate the initial main page?

    I am using the default template; not the "news" template.

  6. Go here please > Settings > Reading and tell us what's selected there.

    Front page displays
    __ Your latest posts

    __ A static page (select below)
    Front page:
    Posts page:

  7. coppershavings
    Member

    Bingo! Thanks timethief. I had the Home page also set as the post page. I've created a separate Blog page and set it as the post page. Everything now appears as I wished. Thanks again!

  8. That's what I surmised. You're welcome and best wishes with your blog.

Topic Closed

This topic has been closed to new replies.

About this Topic