Need help? Check out our Support site, then


Stats not working

  1. The stats on my blog are not working. The page says it is loading but still doesn't load any stats. It has been like this for a few weeks (though I have been able to access it once or twice). Any idea why?
    Blog url: http://bowmandickson.wordpress.com/

  2. Are you accessing your site stats by using this link http://wordpress.com/#!/my-stats

    (1) How are you connecting to the internet and to WordPress.com?

    I'm asking because the way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers. Also note that the main dashboard isn’t designed to work with touch devices through the tablet and smartphone browsers.

    (2) Exactly which browser and version of it are you using. If you don’t know click here to find out > http://whatsmyuseragent.com/
    Note: If you are running IE9 in compatibility mode then be aware that it renders as IE7 and IE7 is not supported.

    (3) Have you tried?
    clearing your browser cache and cookies > http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050
    using the browser with all extensions or add-ons disabled
    updating the browser to the latest stable version (not a buggy BETA browser version) http://browsehappy.com/
    using another browser

    (4) Are you logging in using the secure https:// log-in? see http://en.support.wordpress.com/https/

Topic Closed

This topic has been closed to new replies.

About this Topic