Need help? Check out our Support site, then


Still problems with comments not showing properly - multiple blogs

  1. As far as I can tell, this is happening only in Firefox, not IE or Chrome. A picture's worth a thousand words, so here's the deal.

    On this blog, comments at the beginning of each thread look fine .

    About halfway through the thread, the background changes color. Even further down, the background behind the comments changes to black also, rendering the comments unreadable.

    The same thing happened yesterday with my blog and commenst. Now, the blog entries seem ok. The comments themselves have come back, but they weren't visible at lunchtime. This is what the page should look like . Here you can see that black has been substituted farther down the page for the normal color. From time to time, the page behind the comments turns black, as with the example I showed above.

    The footer has changed also and isn't readable.

    I'm completely flummoxed. Everything else seems to be working fine. It's only that the backgrounds keep changing color, making the text unreadable. I'm running updated Firefox with no extensions or addons. Everything is up to date, I've cleared my cache, re-booted and so on.

    Any help you could offer would be deeply, deeply appreciated. ;)

    The blog I need help with is shoreacres.wordpress.com.

  2. Despite all my efforts, I missed closing that tag after "rendering the comments unreadable". Sorry about that. The new link begins at "This is what the page should look like", and it's fine.

  3. We finally have figured out that the commonality between the two blogs I listed above is that both have a good number of comments.

    One is the Quentin theme, one is the Digg 3 column. In both cases, entries with fewer or shorter comments have no problem. Where the comments take more space, eventually the black background shows up and/or the latter comments are not visible.

    Could this be a theme issue, where something in the coding has set a limit to the space allowed for comments?

  4. This is to let you know I tagged this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  5. Thanks, ma'am! I am subscribed and I am the most patient person in the world. ;)

  6. Hi shoreacres,

    I was unable to reproduce this issue in Firefox, but I'd like to keep an eye on it.

    When you see it happen again, could you let me know the URL for the post in question, and at which comment the background changes? Also, when it happens, could you check the same post in Chrome or IE to see if the same issue occurs under those browsers for you, and if so, if the background changes on the same comment?

    For now, I've made a small change in your Settings that might help matters. Under Writing, I've selected " WordPress should correct invalidly nested XHTML automatically". I'm not sure if that will help, but sometimes issues with pages rendering fully are resolved with that setting turned on.

    Please keep me posted.

  7. Hi, Jackiedana -

    I've been keeping an eye on things, and haven't had any more problem. The two posts where it was an issue had a lot of comments - well more than 400 in one case - and I have to think that was playing into it.

    I'm going to close this thread and open a new one if the issue ever surfaces again. Thanks so much!

  8. Glad to hear things are working better now. I will close this thread as requested, but do feel free to start a new one if you have further issues.

Topic Closed

This topic has been closed to new replies.

About this Topic