Need help? Check out our Support site, then


stop email notifications for comments on other people's blogs

  1. I don't want to be a pest but I have to add my voice of discontent to the clamor. Rafts of email about comments. It will stop us commenting. This will lead to less interaction on WordPress. Not the desired outcome, surely? Strangely, the button below is unclicked...
    Best,
    Conor

  2. Putting the burden on readers to opt-out of spamming their email box is unfortunate. Especially in light of the fact that many people are trying to cultivate trust and community for their blogs. I don't see how spamming them is going to help with this at all. Keeping track of comments/discussions is great but so is freedom of choice. Opting out is aggravating. What happened to ease of use? Opting out is the complete opposite I'm afraid.

  3. Funny that on the stats site there is the recommendation to "comment on other blogs etc" in order to drive up site traffic! I comment only because I am interested enough in the post and as much as I might love them, the emails are driving me nuts. I have been into settings, discussion on my own blog and checked that this is not my default position.

    Who thought it was a good idea to have this box ticked on my behalf, I thought that was my choice to do. Not to have to UNDO!

    Tired, cross and cranky . . .

  4. Same thing is happening here. And I can't do the uncheck thing because I still want email for comments on my own blog. But not for other blogs that I have commented on. :-(

  5. Hi, @kofykat.

    The Notify me of follow-up comments via email option in your comments box is for your readers. As blog admin, you will still receive emails when readers leave comments on your own blog even when that option is no longer available for them.

    I hope that helps. :)

    (I posted something about this for my own readers and you may want to refer to it: http://wp.me/p1GMx0-1A1 )

  6. fogsmoviereviews
    Member

    After getting back a generic response to a support ticket I submitted on the subject, I'm convinced that WordPress has settled on the moronic opinion that this default is now somehow BETTER.

    Unfortunately, I've now had to remove the option to get follow up emails altogther on my blog. Thanks WP! I refuse to email people who forget to uncheck something. Comment replies should not be a booby trapped process.

    I still cant believe WordPress stands behind this, in my year with them, they've seemed so savvy up til now. This change is bush league....

  7. I'm starting to receive complaints from my e-mail subscribers, regarding the influx of e-mail in their inboxes. This is not good. :-(

  8. PLEASE make it a top priority to fix this problem! No one wants a defalut setting that results in getting flooded with unwanted comments on comments, etc. This is VERLY bad for your membership relations.

  9. How much longer is this farce going to continue? I've blogged about it twice, written 2 poems about it, emailed support 3 times, helped innumerable bloggers to change their settings with the retrograde step of removing the options from their own blogs so as not to inundate their friends with spam. Please change it back to how we were, NOW.

  10. I sent one of them to SPAM without opening it first. And that sent them ALL (including ones in the future) to SPAM automatically. No problem anymore because I never read stuff in my spam box.

  11. Hi, I wrote a blogpost last Monday on how to help stop the flood of email notifications in your readers' inboxes and yours. It's got easy-to-follow instructions. Today other bloggers are still being referred to it and I realize more might still do with a little help.

    http://wp.me/p1GMx0-1A1

    These are simple stopgap measures only and is not for everyone because of course the ultimate solution (opt-in, not opt-out) still lies with WordPress. But they may be worth a try. :)

  12. roughseasinthemed
    Member

    To summarise for anyone who hasn't ploughed through all the comments:

    1) This is not a bug/glitch - this is (crazy IMO) change.

    2) And as Raincoaster said, this is a forum not a blog, so the software is different which explains why the default isn't tickboxed here. One could ask why not..... as no doubt there would be a way to do that?

    Regardless, I totally agree with everyone else about this being such a retrograde step and would like the previous default to be restored.

    I would complain to a Happiness Engineer but sadly I can't.

  13. @titabud Thanks but i already know that. I don't want comments from other blogs.

    Guys, the comment system is one of the few reasons I'm using wordpress as opposed to blogger. please fix it, it'll make people not comment anywhere. It's getting frustrating

  14. davinasquirrel
    Member

    Just wanting to add my voice of PROTEST to this new, stupid default setting.

    Also, the advice on managing it (after one forgets to untick the follow comments) is not easily found - the link to that page is not easily found from the user dashboard part.
    This - https://subscribe.wordpress.com/
    Cannot find from - http://wordpress.com/#!/read/edit/

    So I will be turning off the 'follow comments' on my blog so that readers do not get spammed by unwanted comment following. This is totally ridiculous.

  15. fogsmoviereviews
    Member

    Glad to see so many other people complaining about this too.

    Has ANYONE heard from WordPress about this? At least that they've heard our complaints and are considering either changing it back or allowing us to choose our own default settings?

  16. @fogsmoviereviews No, of course not. It's exactly like the topics page: Fixing what isn't broken, creating a rotten User Experience, and not telling anybody about it.

  17. iplayguitaronline
    Member

    Well, this is great. After messing up the avatar system now this.

  18. Been doing a bit of looking and thinking about this. I've noticed that it's only "checked" for me on some WP blogs, and not others. Then today, when replying to a blog where it wasn't checked, and checking it (I wanted the replies emailed on that one), it was then checked for the next post I read from them. I unchecked it for that one when I posted, and checked another post by them, and it was unchecked again.

    I'm wondering if it's not necessarily on by default, but is simply holding its state from the last time we posted on the particular site. Of course, even if this is the case, it still raises the question of what state it's in for people who haven't posted before.

  19. Can I add my voice to the crowd saying I hate the automatic subscribe to comments which has just been implemented. It puts me off leaving a comment on other blogs because it's then followed by a mass of email which I didn't elect. Please change back to opt in rather than opt out.

  20. fogsmoviereviews
    Member

    It did seem to come up set to the previous choice... which is better at least. Still not the best. Hoping WP eventually just comes to their senses

  21. laurasbadideas
    Member

    I think you guys are right about WP remembering comment notification preferences for individual blogs. I have a bunch of long-lived cookies now called opt-out-comm-sub-NNNNNNNN, and it seems like the box is unchecked whenever I visit a blog for which I have one of those cookies. But that means you get different behavior depending on which browser you're using (so, for example, even if the box has been unchecked for awhile when you read a blog at home, you'll still need to uncheck it the first time you comment on that blog at work or on your phone, or if you switch between, say, Firefox and Chrome on the same machine).

  22. Or if you clear your browser cookies (which we all should do at least once a month).

  23. @thesacredpath

    which we all should do at least once a month

    Really? I clear mine every time I log off the interent.

  24. @timethief, that is even better.

  25. @thesacredpath
    We can set our browsers to clear our browser cache and cookies every time we log off the interent and I don't know why others don't do that. Here I am on a 4 year old PC (windows XP) using Firefox 12 and I experience none of the issue others post here about. I also do a full computer scan usually every day and if not then every second day. (brownie points?) lol :D

  26. Yeah, I have an extension installed on my browsers that stop all nefarious tracking and cookies and only allow the ones necessary for sites to work.

    The other day I helped a friend here on the island with a browser/internet issue and found they had over 2,000 cookies. It actually took clearing the cookies and restarting the browser three times to get rid of all of them. Everything was fine after that.

  27. @thesacredpath
    Re: your first paragraph (tracking cookies) please email me that link.

  28. accessiblenorth
    Member

    @thesacredpath

    Re: nefarious tracking - What timethief said! Wait, wait - could you post a link or info here?

  29. Please, WordPress! The flood of emails is making me think blogging is not for me, or at least not with WordPress. And I like it here. This is like waking up one morning in the home you love, looking out your window and seeing your entire communities trash in your yard with a sign reading "New City Dump."

  30. monicaglickman
    Member

    I'm having the same problem - being driven quickly insane by the number of e-mails for comments. I have not (ever) checked the box to receive e-mails for comments but started getting them anytime I comment on someone else's blog. I contacted WordPress who told me I was subscribed to comments - no, I'm not, thank you. Perhaps WordPress will fix the problem, since many others are having it.

Topic Closed

This topic has been closed to new replies.

About this Topic