Need help? Check out our Support site, then


Stop mangling my HTML!

  1. For two weeks, I've looked at WP forums, Google, source code, and a dozen different plugins to solve this issue, and I can't find a satisfactory answer anywhere.

    When I edit a page, I want my HTML to be saved to the database. When I look at the wp_posts table, I wanna see lots of p's and br's in there. And when the page displays, I want my HTML to be displayed. All those p's and br's that were in the database are still there. I don't want the silly WordPress tag-stripping shenanigans to even think about touching my HTML.

    And for whoever out there who is about to tell me to turn off Rich Text editing, here's a clue. There are three kinds of people in the world:

    1. Those who know HTML inside and out and don't have time to code HTML by hand.
    2. Those who don't know HTML at all and don't have time to code HTML by hand.
    3. Those that are dumb enough to think that coding HTML by hand is actually productive.

    The Rich Text toggle is for the last group on that list; it doesn't do anybody else any good. When I put a p tag or a br tag in my HTML using a WYSIWYG editor, by God I want it to stay there.

    So please, just tell me where in the code to turn off all this tag-stripping, tag-replacing, HTML-mangling filtering/sanitizing/nannying that WordPress insists on. If I have to get a doctorate in computer science to do it, then so be it; that's how miserable it is to use the WordPress editor.

  2. Sorry, you're in the wrong forums... Sounds like you're self hosted. Head over to http://wordpress.org/support and repost your question.

    Good luck.

  3. /nod to katm

    @logiczero, you may have posted in the wrong forum, but I am glad you posted that here as it is entirely applicable to both self-hosted wordpress blogs and to blogs hosted here at wordpress.com.

  4. "Those that are dumb enough to think that coding HTML by hand is actually productive."
    No need do offend anybody, especially when *you* are asking for help. People *are* different, so please give other people the respect you would like to get.

    You might try this: go to Options > Write and uncheck following option: "WordPress should correct invalidly nested XHTML automatically". It might help.

    If you have a self hosted wordpress blog, maybe release 2.5 with the new TinyMCE (that's the visual editor shipped with wordpress) will solve your problems.

Topic Closed

This topic has been closed to new replies.

About this Topic