Need help? Check out our Support site, then


Strange characters - UTF-8 option not in WordPress.com

  1. Hi

    When I enter the link to my WordPress.com blog in Facebook (or any other website) all Spanish accents are interpreted as question marks, it looks like this:

    Talleres pr?cticos de fotograf?a
    http://www.quierohacerfotos.com
    fotograf?a, profesional, Espa?a, talleres, pr?cticos, cursos

    You can see it here: http://www.facebook.com/quierohacerfotos

    According to the different available help this can be solved either changing the "DB_CHARSET" line of code in one of the php files (not possible as I can´t access any php or html files in WordPress.com)

    or going to Options > Reading

    and selecting UTF-8 from the drop down menu.

    Where is this option? The most similar one I have found is under Settings > Reading but there is no single drop down menu that allows you to choose UTF-8 there, where is it?

    Also, where can I change the title and the keywords embedded in html? (the two text lines shown when I enter my page link, see above). It´s not the title that appears under Settings > General as I´ve already changed that from "Talleres prácticos de fotografía" to "Aprende a manejar tu camara" (you can see it if you open my website, http://www.quierohacerfotos.com, the title at the browser still says "T?alleres pr?cticos de fotograf?a", I can´t find the fields where I introduced both the title and the keywords to describe my website, I´m going bananas! (if I can´t change the strange characters at least temporaly I can delete them and leave only the web address when refering to my website).

    Many thanks,

    Mj

    The blog I need help with is quierohacerfotos.wordpress.com.

  2. WordPress runs everything on UTF-8 now. You can see that by going to the main page of your site and viewing the source. You will see this:

    <meta charset="UTF-8" />

    Contact staff directly on this. Since WordPress is on UTF-8, then this might be a facebook issue. The contact form is currently closed, but will be back up and running at 8AM UTC on Monday morning, which is about 8 hours from now by my calculation.

    http://en.support.wordpress.com/contact/

  3. One other thing, you have your site in a frame within your website, but from looking at the source code, you have not declared a doctype or any of the other stuff that needs to be in the "head" section of a page on the web.

    Also, since your blog appears to be the only thing on your website, putting it into a frame is not the best way to do things. It is better to map that domain name to the blog here. I highly discourage using frames as they can really mess things up.

    http://en.support.wordpress.com/domain-mapping/map-existing-domain/

  4. Hi

    Many thanks, unfortunately it´s not only Facebook, it happens in any website really, even in my own WordPress blog!

    If you open http://quierohacerfotos.wordpress.com, check the title at the top of browser (on the browser tab title), it reads:

    Talleres pr?cticos de fotograf?a

    I will contact the staff direct, thanks!

  5. See this validation report. At the very least you need to take care of the issues it lists otherwise the search engines are going to virtually ignore your framed page.

    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.quierohacerfotos.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    Seriously though, I strongly suggest mapping the domain name to the blog here rather than the frame.

  6. Hmmm... I didn´t understand very well about the frames but I´ll check the post you´ve forwarded, it kind of makes sense, thanks :0)

  7. This is what I see on my Safari and Firefox browsers in the title bar of the browser.

    http://flippintestblog.files.wordpress.com/2011/06/utf8.png

    The problem is with your browser. Go into the preferences and find the character encoding and set it to UTF-8.

  8. Ok, thanks!, it wasn´t the browser but the company where I registered the domain name (quierohacerfotos.com) which I forward to quierohacerfotos.wordpress.com

    It was your post about the framing that "brought my ears up", thank you :)

    I tested entering quierohacerfotos.wordpress.com in Facebook and it looked beautiful! Then tested again with http://www.quierohacerfotos.com and then it´s when the strange characters showed up again.

    I´m doing some tests but the solution has been found, thanks again, I will definitely get more deeply into learning about frames.

  9. You are welcome and glad you are on your way to a solution.

Topic Closed

This topic has been closed to new replies.

About this Topic