Need help? Check out our Support site, then


Stuck in html editor in 1 post only

  1. kathrynepperson
    Member

    In one of my posts, I'm stuck in the html view of my editor, even though the Visual tab is selected. In other posts, I can access the Visual editor just fine, so it's a problem only with this one post. Logging in on another computer shows the same problem. What's going on???

    Also, in this same post, the images have shifted down a line for no reason. I'm very precise with line breaks and vertical spacing, and several images have shifted down. Clearly, there is a bug, and this has been through a few minor updates of WordPress (.org).

    Any ideas??

    The blog I need help with is kathrynepperson.wordpress.com.

  2. Sounds to me you need to clear your cookies and cache then restart your browser here is the FAQ on this http://support.wordpress.com/browser-issues/

  3. kathrynepperson
    Member

    I'll try this, but since it's also happening on another person's computer, this wouldn't seem like the answer. And why only one post and not all of them?

    If you have an 'in' to WordPress, can you let them know the spacing (line spacing, line breaks, etc) seems to be pretty buggy. It seems reasonable to expect all of that to stay where you put it rather than drifting on its own later. And clearing all formatting and still seeing text wrapping too soon to the next line, forcing me to retype the whole paragraph in the editing window.

    Thanks so much for the idea -- I'll let you know what happens.

  4. I had the same issue on a self-hosted WordPress install, it drove me nuts but I accidentally found a way to clear it -

    Save the post (as draft obviously)
    close WordPress by logging out - don't just close the browser
    close the browser
    Reboot your internet router or modem - power off then back on after a few seconds
    Open a new browser instance
    log back into WordPress
    Go to the posts list in admin and use the "edit" link that comes up when you hover over the post

    All should be well now, but if it isn't

    close that post
    create a new post (it can be gibberish) but be sure to use the visual editor, not the html
    save it as a draft, then close it
    go back to the posts list and open the errant post as described above
    it should now open in the visual editor

    Clearing cache and cookies does nothing in my experience - it is a session ID glitch caused by a momentary disconnect between your router and ISP that corrupts the current editor selection ... no idea if this is 100% correct, but it fits what I've experienced - I have a very flaky ISP connection and get this problem regularly.

    Hope it helps
    Gaz

  5. The other thing I would suggest, is to go to settings > writing and select "WordPress should correct invalidly nested XHTML automatically" and click save changes before opening the post and then after opening it, immediately click the "save" button. If it happens to be some errant code in the post that is causing the issue, then this just might correct it.

Topic Closed

This topic has been closed to new replies.

About this Topic