Need help? Check out our Support site, then


Sub menu not working on iPad

  1. Pop-down sub menu works fine on desktop, but doesn't work on iPad. Using Customized Twenty Eleven.

    http://www.jannpollard.com

    Check the WORKSHOPS link on an ipad and you should see the issue. On an ipad, when you click WORKSHOPS>2013 Filoli Garden, it reverts to the upper line ARTWORK. I am reading others have had this problem, too. Love your software, but this little issue is irritating. My viewer on an ipad cannot find a page unless they go to the sidebar MENU at the very 'bottom' of a page. It might never be found. It does seem to work on my iPhone (G3) as it has a different pop down menu at the top of the page for ALL pages. Thank you!

    The blog I need help with is jannpollard.wordpress.com.

  2. Hi there - I can't reproduce this on my end. The menu works just fine. Can you please confirm what version of iPad you're using? Does this happen only in the mobile version of the site, or is it also a problem if you scroll all the way to the bottom and click "View Full Site"?

    Finally, can you please clear your browser cache to see if that fixes this? http://www.wikihow.com/Clear-Your-Browser%27s-Cache#Safari_for_iOS.2C_iPhone_and_iPad

  3. As I had stated in an earlier email, the cache clearing fixed it, but only for one day. It was right back acting up the next morning. Very frustrated.

    Jann

  4. Hi Jann - what version of the iPad are you using? Does the submenu fail to function in both the mobile and the full version of the site on your iPad?

  5. My iPad is 6.1.3 version.

    Right now it is working so it is difficult to respond. When I go to Safari, call up the site on my iPad (I presume this is what you mean by full version), it is currently working. But this was the version I was on when I made my initial inquiry and it wasn't working.

    I haven't used the mobile version of the iPad too much as it doesn't work well. Right now I am trying to get to the jannpollard.com site, and the sub menu (upper right corner) won't let me click to Manage by Blogs. Thus, I don't use it.

    On my iPhone, (G3 in 6.1.3 ) in the full version, the pop down menu works fine. And again, I get frustrated in the mobile version, so don't use it. It doesn't work very well, and you lose most of the visual. Being an artist this is important.

    Thank you for trying to figure this out. My sister (1787themusical.com) is having the exact same problem with her sub links. She has sent messages to WordPress also.

    Jann

  6. I have tested on my own ipads (a new ipad mini and an older ipad 1) and both are working fine for me.

    Are the menus still working correctly now a day later?

  7. No, the menus are terrible. On my site: http://www.jannpollard.com, when I click ARTWORK>Artwork Collection, it goes to BOOKS underneath. When I click WORKSHOPS>Filoli Garden, it goes to HOME above!! Very frustrating for the viewer and the web designer. Yes, I have emptied my cache. Thank you for working on this problem, which I have read, many others are having the same problems.

  8. I still cannot make this issue appear in my testing using either of my ipads or my iphone.

    Just to check, are you using safari on your ipad? Or are you using a different browser? Do you have any display settings on your ipad changed? For example, do you have zoom or large text turned on in the "accessibility" settings?

  9. Yes, I use Safari. No, I am not using zoom or large text.

    thank you,
    jann

  10. I think the issue may be the fact that you have clickable top-level tabs. You might want to look into switching to static parent tabs as described here:

    en.support.wordpress.com/menus/#creating-static-parent-tabs

    Take a look through that page and let me know if you have any further questions. I'll be happy to help.

  11. Well, I am still quite frustrated!! I have made static-Parent-tabs of all the pages, and even moved any menu items that had drop-down menus to the bottom row to see if that could solve the problem. Please review my menu again at jannpollard.com and you will see those drop-down sub-items are overlapping or something, and cause them to jump to the row above. Yes, I have reloaded. Could you suggest a suitable work-around? I certain hope wordpress is working on this problem.

  12. I do not know what to say. I have again tried all of my iOS devices and clicking on the menu item takes you to the correct menu location.

    Let me just throw out some more random questions in the hopes that we can narrow the issue a bit more.

    When you are experiencing this issue, you are seeing the black menu background of the "desktop" site, correct? You are not viewing your own site in the WordPress.com app, you are using Safari? Which ipad do you have 1/2/3/mini? For the heck of it, could you try clearing Safari's cache?

    I really wish that I could be more help on this and am game to keep trying as long as you are. But I simply cannot make the problem replicate itself when I try myself.

  13. Thank you for your persistence, too.
    Yes, I see the black menu on the desktop and on the iPad. yes, I am using Safari. On my iPhone (G3), it works well with the blue pop-down menu.
    My ipad is version 6.1.3. It uses wifi and G3.
    Yes, I did empty the cache. It worked fine, then I shut down, reopen and it is back again, not working within minutes.
    My sister's site does the same thing at http://1787themusical.com/mobile-notice/
    Read her notes also, please. Thank you!

  14. I wish I had some good news to update this with, but I do not. We simply cannot replicate the issue. It may be that our caches aren't seeing the same stuff that yours is.

    Just out of throwing stuff at the wind, maybe try clearing cache and then doing a full restart (hold down the home and power button until you see the screen go blank and the apple logo come up).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.