Need help? Check out our Support site, then


Subscription Emails Do Not Send Until Someone Visits the Site

  1. I schedule posts days or weeks in advance. I have been doing this on various wp.com blogs for years and it works great: Schedule the post... when the publish date/time hits it goes live on the site and the subscription email is sent to all followers.

    However, this seems to have stopped working as I'd expect it to work. I'm not exactly sure when it stopped but it has been acting strange for a least a couple weeks.

    What it is doing now is that there is no email notification sent to followers until *someone* goes to the site after the publication date/time for the new post. For example:

    We had a post scheduled for 7am Eastern today. No email was sent. Someone went to the site to see if the post had been delayed for some reason at about 7:23 am EST. Immediately, the subscription email went out. Same thing happened yesterday at 7:10am.

    Is anyone else seeing this behavior? I tested this on a second wp.com hosted blog this morning and had the same results.

    Is this a bug in wordpress 3.5 perhaps? I haven't tested it on my self-hosted sites yet but will do so when I can setup a sandbox for it.

    I know this is not a personal preferences issue as it is happening to all followers.

    Incidentally, if we "Publish immediately", the issue does not occur. As soon as the post is published, the subscription email is sent. I would assume that's because we are immediately "visiting" the site upon publication.

    The blog I need help with is todaysauthor.wordpress.com.

  2. It has been publish after the first visit that happens after the scheduled time for several years - that uses CPU / server resources more efficiently so they don't need to have a special clock running all the time to check for scheduled events -

    I tested this for myself over a year ago here and found that publish after the first visit was the way it works, that also worked that way back around 2.7 or so - the check for scheduled posting code was in the footer

  3. Hmm. Really? I was reasonably sure I had this work as I expected it to work just a couple weeks before the new year. The site on which I scheduled a post is exceptionally low traffic when there hasn't been a post, so I'd be surprised if someone accidentally went there to trigger the emails.

    Then again, I use so many self-hosted sites now that I could be confused I suppose. I guess I understand the decision to go this way, but I don't like it.

Topic Closed

This topic has been closed to new replies.

About this Topic