Need help? Check out our Support site, then


Suburbia theme- post doesn't show image?

  1. on my site http://testsbart.wordpress.com/

    The new posts dont show the images in the post like the theme does on the test page
    http://theme.wordpress.com/themes/suburbia/

    The blog I need help with is testsbart.wordpress.com.

  2. Did you insert images into those posts, or were you just expecting the images that were on the demo screenshot to appear on the front page like in the picture?

  3. Because if you didn't put any images in the post, no images are going to show up on the home page. Those were just examples, they aren't actually going to appear on your site.

  4. Yes their are images in the post..

  5. I created test posts each with an image and none are showing up on the frontpage

  6. On the main page, Suburbia doesn't display regularly inserted images. You need to set a featured image to each post. See here: http://wpbtips.wordpress.com/2010/08/23/featured-images/

    Suburbia description notes
    live demo site

  7. Also we Volunteers the blog is "private". That means we don't know if the images are the correct dimensions specified by the theme or not and we cannot read the source code and discover what you did and tell you how to resolve this. if you want Volunteer help I suggest that you change the blog visibility to option 2 so we can help. Otherwise you will need to contact Staff as they do have backend access to blogs.

  8. Thanks! I didn't know about the "Featured image" setting in the bottom right before

  9. You're welcome and best wishes with your blog.

  10. I am curious to know if the response from timethief worked for sbarbary. I am having the same issue but have not been able to resolve it yet.

    I switched to this theme, and would like to have featured images associated with the posts. Perhaps it only works on new posts when they are first published? Please advise, and thank you.

  11. Still have my problem....no images on home page.

  12. When you make the post. look in the bottom right at "Featured Image" and select an image there that will appear as the main image for the post!

  13. See here please > Setting a Featured Image > http://en.support.wordpress.com/featured-images/#setting-a-featured-image

    If you don’t see the Featured Image module on your Add New or Edit Post page, please make sure you’ve selected Featured Image in your Screen Options.

  14. Thanks! I think I'm starting to get it....it appears this works when the image is actually in the media library. If I've only ever linked an image to a URL, it doesn't seem available.

    Does that square with your understanding? Thanks so much for your time and help.

  15. Yes, the image must be on WordPress.com servers ie. in your Mdeia Libraray.

  16. **headesk*** That would be "Media Library" - sorry. :(

  17. Thanks! I'm on a roll now. Much appreciated!

  18. That's great to hear. Happy blogging! :)

Topic Closed

This topic has been closed to new replies.

About this Topic